MyCloud v2.xxxx 4tb Brick after last updated to OS5

Thank You for the answer, but i did 40s resets 2 or 3 times yesterday, and still it was impossible to access dashboard. (Power off, press reset pin, power on, wait 40-50s). Blue light is blinking all the time, after reset nothing is happening (HDD is working as during reset, blue light also)

Check if the router did not assign another IP to your device. and access from another browser or incognit mode to avoid cache

I have static IP on router for MyCloud (i checked without static, and its the same, not working).
I just made 40s reset (even 60s) and didnt help. Still no access to dashboard.

After 5th (!!!) 40s reset, i was able to log in to dashboard. After log in MyCloud didnt had internet connection (i have no idea why, because i alredy connected MyCloud). I went to cloud access and disable it, but of course screen hang on “updating” info for minutes.

Than i refreshed page, and went to utilities to do scan disc. I click it, but after this i had again “updating” info for minutes.

After refresh page i lost access via dashboard. :confused:

Small update:
I tried different router, different place with different internet connection, different lan cable - everytime is the same, so it’s for sure MyCloud problem.
Sometimes (one time per every 5-6 40s resets) i can access dashboard.

But even then i cant do reset, i cant download report, and MyCloud dont have internet connection.

1 Like

I faced this similar issue after updated to os5. Only way is to disable cloud access and use it as a local nas.

If not, try to revert back to good old os3.

Problem is that even if i can access dashboard, i cant change aby options because imidiately i have msg “updating” and device is frozen, and i have to reset, and “fun” is starting from begining :confused:

One suggestion is to remove your hdd from MyCloud enclosure and connect to a linux system. try to mount sdX3 (where X can be “b” or “c” depending on how many hdd you have in your linux system) as that is the volume where uImage and uRamdisk is located under the /boot folder.

Overwrite it with uImage-recovery and uRamdisk-recovery from → usbrecovery.tar.gz (unzip into your computer)

mv uImage-wdrecovery uImage
mv uRamdisk-wdrecovery uRamdisk

After that, umount and disconnect and put back to the MyCloud enclosure and bootup. You should use the old IP address and access via Web-GUI (Safe mode).

Upload the original os3 firmware (.bin file) here to revert back.
→ OS3 firmware (xxx.bin)
WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links

After you recover back to OS3 , you can consider if you wanna try upgrade to OS5 again from there.

Thank you very much for this advice, and i Hope it should work, but i dont have a knowledge in Linux (i didnt work on this system), so better i will not try it.

Btw - how WD can still cant find a solution? They should prepare file/files just to copy to USB, which users should just plug (to the damaged because their firmware upgrade) and it should solve the problems :confused:
But i dont think its technically possible.
Otherwise they should take those devices (because they are of of warranty), fix problem with firmware and send back to users.

OK - - - can we be honest here?

This is a MyCloud single bay drive, correct? Probably more than 4-5 years old?
If not - - - ignore the rest of this post.
If so - - -Read on

So this is an older device- - -
Regardless of the O/S; The data should be backed up somewhere. . . if not. . . .first order of business is to get the data off the drive. Forget WD software. . . . At this point. . .I would give up on the WD software. . . .and put the drive in a USB enclosure and get software that can read the Linux formatted disk.

Now, with the data secure, recognize that the five year old device is fully expendable. Knowing this. . . .the method that @alanokm has suggested should work. People have been doing this for years. Look for a topic regarding “unBricking” in this subforum dedicated to O/S3 MyCloud devices

If it all works - - and I have hopes it will - - use it on O/S3. . . and DO NOT be tempted to upgrade to OS/5. If you feel compelled to have system running modern firmware. . .there are a number of reputable NAS manufacturers.

As for WD finding a solution. . . .do not hold your breath. They are CLEARLY all in on OS/5 - - for reasons (edgerover) - - - and are totally unsupportive of anyone using OS/3 going forward. Can they provide a fix via USB? Sure. . . except none of the current (or older?) systems are setup to boot from USB. (I might be wrong on this) so that won’t help you.

Can WD make it right? Yes. But it’s expensive. . . involves shipping people like you a new unit. . . and I don’t think they will do it.

(Edit: Note that the debricking methods SHOULD leave the data intact. . . . but in your case, where the analytics have shown bad sectors - - -data integrity must be the priority)

(Edit: Note: Hey: How many people here realize that the “analytics” that you so blithely sign up for go to the extent of identifying individual devices (MAC address), and transferring of full data logs?)

Yes, it’s about 4-5 Yeats old device, but it was working until WD upgraded firmware. It’s embarassing for WD as a company, that they damaged working correct devices by sending to them incorrect/wrong/full of bugs firmware
, And now they have no idea what to do, waiting for customers to repair this by own using “house methods” like unbrick or something like that.

From couple days even resets dont helps and with my device is no connection, all the time with blue blinking light,

so i have a question for WD - where can I send You this device??? I would like to show you how You destroyed my MyCloud :confused:


1 Like

My age is showing.

My advice is “get over it”. Stuff happens. Especially to 5 year old consumer electronics.
If I look at my spending; I average $1000 a month (Like $12000 a year) on replacing things that fail due to age or my own incompetence. It’s insane. . but that’s life. Seriously. . .somethings CAN be fixed with a liberal application of money.

Of course; some things are irritating. And costly. Is your data backed up? If so - - - Then there is a quick and easy solution.

If you don’t have the coin - or inclined to take on a project - then look at this as a learning opportunity.

If you don’t have the data backed up. . . .you have just learned an important life lesson. . . and you have some work to do. PS: Don’t forget to get this when you are done.

Edit: I am not personally recommending any brand or product; the links are the results of almost random product searches. However. . . you notice a theme in those links, correct?

Posted by a dweeb with a drawer FULL of WD external drives, and a shelf with three WD NAS devices. WD Fan boy I was. . .until the lack of support for the MyPassPort Wireless; the red drive SMR/CMR debacle last year, and finally the OS/5 rollout

1 Like

oh - - - a brand loyalty is a thing. As I noted above, I have been buying WD products for a loooong time.

But one must recognize when a company is moving in a direction you don’t want to go.

Example 1: Adobe Lightroom - - > My go-to photo editing program. Used it since it launched. Bought maybe four of the six versions until it went to subscription model. Now I use CaptureOne.

Example 2: Canon - - > 8 (or more?) cameras and maybe 20 lenses over 20 years. From the start of the EF product line to the end. Not moving on to the not-quite-as-good-but-definitely-more-expensive RF product line. Why do expensive EF lenses need an expensive adapter to mount to an RF camera? * * * * I hear Sony makes good cameras.

Example 3: Garmin - - > I had a Car GPS bricked by a firmware update, well outside of warranty and likely past End of Life. Got on the phone with support. . . they did a remote session with the GPS plugged into the PC (before that was really a thing with PCs). . .and 30 minutes later they were sending me a brand spanking new (and more capable) GPS. The unit they sent was announced the previous week. . and I had to wait a few weeks until it was shipping. Since then, I have bought a Garmin Marine GPS and now wear Garmin watches. :wink:

I have the same problem and live in the UK. I would love to take this case forward, any advice?

I do not live on UK (i’m from Poland), but i will keep my fingers crossed for this case. I had a working device but producer (WD) damaged it by sending firmware to my device.
It should be end for them for all NAS devices, nobody should but MyCloud anymore because one day WD can destroy device by firmware :face_with_symbols_over_mouth:

“My advice is “get over it”. Stuff happens. Especially to 5 year old consumer electronics.”

I understand you, but i wouldnt say anything od device would stop working because of damage or just because is old. It stopped working because WD upgraded firmware which destroy users devices.
In electronic devices one of the most important thing is lifetime. If producer is making lifetime shorter by sending firmware with bugs, for me it’s only one Word - scandal.

If the device is old and the company don’t want to give support for it anymore, fine… but just don’t release something knowingly that it will fu** up old devices… that is bad

1 Like

This it very true.

OS5 originally was released to the more recent higher end devices. And the users were in an UPROAR over the slow and inefficient indexing process. This software should NEVER have been released for the older MyCloud and MyCloud Mirror devices. The results were entirely predictable.

Problem is that short of declaring EOL; there practically was no option - - since clearly there are no plans for any software maintenance for OS3.

I can’t belive WD released OS5 for older devices “not intentionaly”. For sure they should test it on all devices. It looks like somebody in WD had great idea how to increase selling new MyClouds - "lets destroy/damage old MyClouds, and users will run and buy the new one… " :smiley: :smiley:
Yeah, right :face_with_symbols_over_mouth:

After many attempts I managed to solve brick my cloud. I have same problem as you guys. What I did is next.
After many resets no success.
I managed to asces to dashboard and control device for 5-10min but it brick again.
I think indexing is problem.
So I pull out hdd instal linux driver and save my data.
Then i put back hdd inside and when i put device in power after first screen to log in I loged wih my password and get message that device is booting up please wait.
Then I reload page and get in dashboard (blue light was still blinking).
But I think it’s limited control and I didn’t have all main icons (cloud ascess).
I go to settings and format disc.
after 5-10 times of trying.
And I managed to format disc.
After that my cloud start to work normaly.
Nexi I have done is: dics test, sistem test, analyze disc and do the factory reset.
Then I set up it like new and now 7 days work normal and fast. I’m still testing it but no problem. I copy 50% procent data 250gb and still working normal. I hope this is help cheers