How to restore a WD DX4000 in RAID 5 with 0xD9 error?

#1

Hi,

I’m helping someone to restore or reinstall a WD Sentinel DX4000 in RAID 5 (4 x 2TB) which cannot initialize (error 0xD9).
Who can tell me the right direction?

The DX4000 displays.
Initializing OK
Searching …
and then
STARTUP
FAILED: 0xD9

  • The RAID 5 parameters were discovered and the data could already be recovered.
  • A XOR test shows several errors in the RAID 5, which should be corrected first.
  • According to the S.M.A.R.T. values, all drives are healthy. (One with very few bad sectors was replaced by a clone of the same model.)
  • Factory reinstall possible, but if possible not keeping the data and correcting the RAID 5 errors would be prefered.

Questions

  1. Is there some procedure / tool to correct the RAID 5 errors?
    In the documentation, I only found the way to hot replace a hard drive and reconstruct the RAID 5. But what about correction of errors accross existing drives?

  2. What does the 0xD9 error exactly means?
    Does the start fails because the system is searching for some DHCP connection ; so should I link the NAS to some router for the start to suceed?

  3. How to reinstall or repair Windows Storage Server 2008 R2 essentials?
    Did the DX4000 come with a Windows CD and should I ask the owner for it?
    How do I access the DX4000 as it refuses to initialize ?
    How do I access it from an other computer and can see Windows errors at start? :
    just plugging in RJ45 wires in a router or do I need some client panel software?

Thank you very much for your help.

#2

Basically you need to contact WD to get the recovery ISO and rebuild the box. When they discontinued these they no longer have the downloads on the public site.

I think you have a typo?
•Factory reinstall possible, but if possible not keeping the data and correcting the RAID 5 errors would be preferred

I think you wanted to keep the data but that may not be possible without a 3rd party raid recovery software… On the one hand it is a normal windows server, it is just headless. So there is no way to see or tell what is going on until windows is loaded. And of course if windows will not load for any reason, you are in the dark. So the recovery process involves booting from a special thumb drive that will allow the server to “talk” to a desktop to lay the OEM image down and reconstruct the Raid Array.

Another FWIW you said you cloned the drive with the same Model. It actually has to match all the numbers Model:firmware The DX4000 has a whitelist of drives it will accept and it just will not work with others. That said there is a public download now that allows other drives to be used. But of course the box has to be booted into windows to run that enabler.

#3

If you need it, here’s the link they sent me last night (25MAY16) for the recovery software;
http://download.wdc.com/private/PANAM_SvrRecovery_1_7_6_21.iso

Be advised that the guide is wrong, your disk has to be a 16GB and USB 2.0. Anything larger and USB 3.0 wont work.

Trying to fix the same problem you have right now. I’m only one step ahead.

#4

Thanks @Bob_Russo
Did WD happen to save if the drive enabler “fix” is in that build?

#5

No mention of it Gramps. actually the first I’m hearing of such a thing is in this very post. I do have a unit under warrentee so I’ll submit a ticket asking about it once this current ticket is closed.

I have a lot to report about this restore. It’s been about sixteen hours of torture but I’m confident I’ll hammer out all the kinks in a day or so.

#6

as a rule it really should not take over 6 hours. Are you into windows yet?

#7

Well… I have two DX4000’s. Trying to bring one out of 0xD9 (this one was an ‘as-is’ purchase on ebay) and simultaneously simply restore the other without data loss.

I’m not complete yet. but I have made progress. I have them both restored but I’ve not yet been able to configure them yet. more on that in a future post.

I’ve run into issue after issue after issue doing this. In fairness to the DX4000’s, None of the issues I’ve had are actually server related. Every issue I’ve had is either client machine or user related. I started this mission improperly equipped and without complete knowledge. I’ll document all of this in future posts to this thread so some poor dude doesn’t have the hours of misery I’ve had. but I gotta finish it first - I’m at work today and wont be home until late this evening. Probably wont hear from me till close of business Saturday (28MAY16).

#8

No worries, If you had a raid 5 and try to go to Raid 1 without cleaning the drives it will go 5 days before it gives an error. I just wanted to be sure you were not waiting for failure :slight_smile:

If you still have both thumb drives there are log files in the wd folder that can be informative

#9

OK So I successfully brought a dx4000 out of 0xD9. She’s up and running, kicking butt and taking names. The manuals I’ve found online were incomplete and inaccurate.

Before I begin though I want to mention Gramps. I’ve been aware of his writings for years but never needed to ask any questions of him because everything he ever wrote to others worked for me. He’s been helping me out and explaining things to me for more than half a decade without even being aware of it. In fact, the reason I was confident enough to buy a headless Sentinel in 2011 was because of his writings in this forum. While I was always aware of, and admired him, it wasn’t till I attempted this recovery that I realized the scope and magnitude of his contributions. literally every question I had during this was answered by him in various threads.

Gramps you are truly an asset to the home technology enthusiast. An invaluable mentor to both young and seasoned system administrators. There might be more of us than you realize. I’ll now speak for the hundreds of us that lurk this forum, and the others you contribute to, and let you know that you are appreciated, you have our respect and our gratitude. Thank you for every thing.

Anyway …

#10

What you’ll need;

  1. the recovery ISO
    http://download.wdc.com/private/PANAM_SvrRecovery_1_7_6_21.iso
    (use Firefox to download. When I used IE to download it did work but the file size was slightly different and the buttons in the menu started with a dot. I cant explain why this is but I was able to repeat it on a few different machines. Just use firefox).

  2. a 16GB flashdrive.
    (an 8GB will not work despite the manual saying that it does. Nor will a 64GB flash drive. using a 64GB drive will result in an unspecified error. a 32GB may work but I didn’t have one to try. if you’re using an SD card in a USB reader it cant be read-only. it must be write enabled).

  3. a USB 2.0 port
    (plugging the flashdrive into a USB 3.0 port (these are blue) will result in an unspecified error.)

  4. a Windows 7 client machine
    (WinXP & WinVista will almost certainly work but I didn’t test that. Win8/8.1 may also work but I didn’t test that either. Win10 will definitely NOT work.)

  5. a DHCP server on your network.
    (your router probably does this for you. if you don’t manually assign IP addresses you’re good to go.)

#11

Recovery;
1- Mount the recovery ISO on your client computer
( http://download.wdc.com/private/PANAM_SvrRecovery_1_7_6_21.iso )
(this can take quite a while. I use ‘ImDisk Virtual Disk Driver’ ( http://www.ltr-data.se/opencode.html/ ) but you can use what you like. this portion can be done with Win10.)

2- put your 16GB stick in a USB 2.0 port (i.e. not the blue port)

3- run setup.exe from mounted iso. click ‘recreate my storage’ and click your way though this till the drive is created.

4- put the 16GB stick into the dx4000 (I used the port closest to the Ethernet ports if it matters)

5-. while holding the reset button in, power the unit on
(don’t let go of the reset button till the LCD tells you the process has begun (I forget the exact message). Don’t power off your client computer or take it off the network while this is going on. After some time it will report success or failure. mine failed twice. If this fails that’s ok - just go back to step two. the 16GB stick is destroyed in the process of using it. if you try to reuse it you get the error, ‘invalid config’. its one shot one kill. you have to return to step 2 after use whether it failed or succeeded. This can be done with a Win10 machine)

6- put your 16GB stick back in a USB 2.0 port (i.e. not the blue port) of your client computer.

7- back on the iso setup.exe click ‘perform a recovery’ and click your way through that till the drive is created.

8- put the 16GB stick into the dx4000 (I used the port closest to the Ethernet ports if it matters)

9- while holding the reset button in power the unit on
(don’t let go of the reset button till the LCD tells you the recovery process has begun (I forget the exact message). this will take a while. Don’t power off your client computer or take it off the network while this is going on. if you get the message ‘bad storage’ go back to step three. This can be done with a Win10 machine)

10- after your recovery is complete if the LCD doesn’t list the machine as ‘WDSENTINEL’ leave it alone. it’ll reboot a couple times but eventually come back up and say that.

11- now switch to your Win7 machine and point a browser at http://WDSENTINEL. download and run the setup (this may take a couple tries) and go through that. This will seem to work on a Win10 machine but I assure you’ll have issues in the next step if you use Win10)

12- Point a browser at http://WDSENTINEL/Connect and download and run that. (This will NOT work with Win10. If you used Win10 for step 11 you’ll be told that your password is wrong.

13- Buy Gramps a beer. you’re done.

#12

Aw shucks… [blushing smiley] That’s the kind of stuff you want your Momma to read about their little boy LOL
I suppose it is good to have lurkers, but don’t wait another 5 years to help someone :smile:

I think in step 4 when you said if it fails you need to go back to step two not three.
I think it would be a good idea in there to add to look in the root of the thumb drive for the \wd folder as it will have a log file that should at the end tell what type of raid it created etc. It took me off and on 6 months to restore mine once. It shipped to me with 4 drives and I ran it a while and decided two drives would be enough storage at the time and that way I could use Windows Server backup. Well the raid data is written to the disk so it was trying to create a raid 5 with 2 discs. The recovery would run for 5 days and then fail.

I think you should also mention that the “client pc” needs to be left on during this process of recovery and you need a DHCP server on the network.

And I think we should say if you have a problem don’t fight it, ask, Bob or someone else might have the answer.

I just wish we could convince Microsoft to ship an OS like this one again. One that does not have to be a Domain Controller. Either run in workgroup or join a Domain just like Storage Server 2008R2 Essentials. And it would be really great if it was available to all and not just OEM’s, but I would settle for just OEM’s

Thanks again for your kind words and for participating in this forum.
Gramps

#13

Thanx Gramps. Correction made

#14

So whats the deal, SOSdonnees. are you good to go?

#15

So looking at step 6. Some folks have had problems getting thumb drives to work and different brands work. I wonder if they were using blue ports on the client PC. Too many variables LOL

#16

Ditto…

#17

How big is the PANAM_SvrRecovery_1_7_6_21.ISO file? I’m getting a 1k download.

#18

9.54gb

#19

Verify your download

C:\Users\Budro\Downloads\PANAM_SvrRecovery_1_7_6_21_.iso:
Verified: Unsigned
File date: 1:53 AM 1/14/2017
MD5: 32031F2454D3510D7CE2BF5891F7D25D
SHA1: EF0E132813182B2202A5FF54180C840BEE44F59E
SHA256: 6D511FC43FEFBC088E6A069397539B575AA6E81067D0A5BC81E1FEF12CDCD1B1

#20

Gramps hope that you can help

My hobby is my collection of music, movies and documentaries. I have been using a WD DX4000 running raid 5 with 4x 2TB. The sequence of events which led to my problem:

  1. The ethernet failed and as the server is headless setup, I could not access it.
  2. I bought a replacement server and now a hard drive on the raid has failed.
  3. The system won’t boot.
  4. Because of the way the WD works with the drives it only accepts certain drives. As these are hard to come by its possible to do an update to get around this. On a previous occasion I updated the whitelist to allow more drives as I could not find the listed drive.
  5. Doing a recovery on the system requires a usb stick reboot but this software doesn’t have the updated whitelist and so it will not complete the recovery.
  6. I need to recover my data and move it on to another hard disk/s what do I do?