How to regain ssh access after firmware update?

I’ve got the “MyCloud” (plain, no suffixes); just updated to firmware version 2.41.116.

After the update, I can no longer access the device via ssh. First of all, it seems that /root gets wiped at each reboot, so my /root/.ssh/authorized_hosts file containing my ssh keys for passwordless login was unhelpfully removed. I would love a fix for that (i’ve got scripts that automatically ssh and need this) but I already know about that and was prepared to log in using my password and put the file back. But it no longer recognizes my ssh password which I have saved in my keychain:

Permission denied, please try again.

So I poke around in the UI interface and find under Settings > Network > Network Services > SSH > Configure that I can set a password. So I set it to what my password should be, and it seems to “take”. But… I try a new ssh session and it still doesn’t work!

I’ve always logged in with root@, but I also tried using my username from the web login - that didn’t work either. I tried turning ssh off and back on. Still didn’t work. I tried rebooting the device again. No luck!

I do everything with this device through ssh (mostly via rsync) so without ssh access this device is basically useless to me. The device is remote so if I have to do something physically with the device it will be out of service until I can make the trip and my nightly scripts will start failing. Help?

For the v2.x single bay My Cloud units running recent firmware, the default SSH user login isn’t root. It is sshd. One should have had a popup dialog window indicating this when one enables SSH in the latest v2.x firmware My Cloud > Dashboard > Settings.

Wow, that worked! If it was mentioned in the pop up I totally did not see it. Thank you!

Now to figure out how to switch it back over to root; otherwise I’ll have to find every reference to root@ and change it to sshd@…

edit: aha… editing /etc/ssh/sshd_config. I assume I may need to do this every time I update the firmware :-/