How to finally disable media server on EX4 under most recent firmware

Hello there,

after reading a lot around the web about all the problems the EX4 is having regarding its media server eating up all the CPU and constantly grinding the disks I tried everything I could find on Google and at the moment I am a bit stuck. My device has firmware 2.11.133 and this is what I have gone through.

Stopping wdmcserverd and wdphotodbmergerd works through SSH as described on many tutorials.

update-rc.d wdmcserverd disable and the same for wdphotodbmergerd does not work, I get an error that update-rc.d is not found.

Using chmod 644 on wdmcserverd and wdphotodbmergerd to stop them from being executed doesn’t work either, the privileges are restored after every reboot.

Renaming both services results in the same outcome: they are restored after reboot.

Trying to change the excludepath in the wdm.xml with a text editor and adding “shares” doesn’t change anything as the wdm.xml is also restored after reboot.

Changing the twonky server settings for not searching pictures is not possible here or I am blind as I didn’t find this option. There is a prompt to write in exclusions and putting “shares” there doesn’t do anything, wdmcserverd rattling away after reboot.

So WD, as you might already know (sigh), this device is not capable to run all the useful stuff you wanted it to run without shredding the hard disks and lots of guides here and on other sites in the internet are a testament to that. Please give us at least an option to kill both these services for good so that we don’t have to SSH into the device EVERY REBOOT!

Luckily I am not in the camp who have bought this thing for its retail price, the price I paid for a used unit amounts to the same price of only the four hard disks in it so I can move on to another solution if nothing helps. But I’d rather like WD to step up and fix that thing fast please!

Hello there,

That sounds like its a good suggestions, please be sure to post this on our ideas board, please follow this link so you can post this:

https://community.wd.com/c/network-attached-storage/network-product-ideas

This is not the Media Server aka Twonky, the above is related to the Cloud service. If you disable the cloud service, then the named indexing services are off.

Okay, thanks for the correction but I am not sure it will really do that, have you tested it? But aside from that I actually want to use the MyCloud on my devices and it works without the strange service rattling away.

Are you joking?

No, I have tested so much but as I don’t want to lose the MyCloud, which your suggestion probably is leading to, I am asking that to find out.

Who else would you believe beside the manufacturer?

Disabling the cloud access (Settings -> General -> Cloud Access OFF) stopps the indexing services and disables the accessibility to the My Cloud from the Internet. You claim these indexing services to stop, this is the way how to stop them.

Alright, thank you, overlooked that you are WDStaff, sorry.

Now the second part of the question remains unanswered. With that Cloud service off I won’t be using MyCloud anymore, correct? Is that on the local network AND from internet or ONLY internet?

Cloud Access OFF diables the ability to use the device as Private Cloud environment from outside, but the device is still active as your NAS storage within your home network.

The two indexing services are needed to create the thumbnails and folder content if you want to use your device as Private Cloud from outside.

Remember, you have a multi-functional device. “My Cloud” is the name of our network attached storages, “My Cloud” is also the name of our Private Cloud environment, offering you Cloud services which are powered and provided by your device. Of you disable Cloud Access, then the device is a normal NAS without Cloud capabilities.

Anyway, the indexing services may run a certain time until all content is indexed. This may last a while, depending on the usage of the NAS and on the amount of content to be indexed.

The way to have better access to Twonky is by the twonky html page. You can deniable media scanning on particular volumes, directories and limit what it is looking for in its scan. Be default media scanning is ON as is scanning of media receivers. I turn these off.

Twonky still sparks up at odd times without any reason i.e. when a USB backup is being done (which kills the backups), even when USB media scan is disabled in twonky settings), but it will stop twonky grinding away at your EX4 volumes.

BTW, you can limit the scan interval within the Twonky settings. By default it auto-scans. I have fond this not to be a good thing if you are often making changes to the media, fine if the unit is stable.

Turning off Cloud Services did actually stop the two services from running so thanks for that.

Unfortunately, as I predicted, using the “My Cloud” app from WD on my smartphone is not working anymore. Regardless if on local WiFi or from outside.

It is a bummer really that you have to disable the actual “My Cloud” part which is a dominant factor of the usability of that device to be actually able to use it. Next NAS will probably be something else, for now I can live with it.

As I said from beginning, the one thing is related and combined to the other.

Activate the Cloud Access, position the My Cloud somewhere in a corner and let it do its job. The indexing services need to finish the initial scan, then they are not stressing the device again. But they need to run at least one time completely til the end.

In German language we say: you have to choose between the devil and the deep blue sea.

I don’t think that I want to do that. I put several GB worth of photos on it nearly every weekend and that would surely kill the drives quickly. I think I’ll live with it as it is now.