How to expand RAID 5 capacity in WD MYCLOUD DL4100

Hi, we have a WD MYCLOUD DL4100 with 3 x 6TB NAS drives configured in RAID 5. As the current RAID5 volume capacity is almost hit its ceiling with 7% remaining. We would like to increase the volume capacity with another 6TB NAS WD RED drive installed on the 4th bay. The firmware has been upgraded to the latest version. So how and what should we do to expand the RAID5 capacity on the fly without jeopardizing data integrity and to avoid downtime? Thanks in advance anyone for the relevant advice.

Hi Psalm3745,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support
The link below will allow you to call support.

Brandon - that was not very helpful!
what’s the point of a community board, only to have you tell someone to “CALL SUPPORT” or “CREATE A TICKET”

You should have this answered and can’d.
Paste your answer, or point the user to a Knowledge Base answer.


I have a similar question regarding how to expand the capacity in a RAID 5 configuration.
Did anyone ever find the answer?

I think, as long as you’re not at the storage capacity of the DL4100, you initiate the upgrade through the web-dashboard and follow instructions, which I guess, example, you have 4 4Tb drives is the chassis and with to put in 4 6Tb drives, I think you remove the 1st drive and insert the 6Tb drive and allow the RAID array to rebuild and repeat this for the second, third and if you have a 4th drive, replace the 4 drive.

I think once you’ve replaced the last drive in the RAID5 array and the array is rebuilt/repaired that then the partition is extended to utilise all the available space to include the volume and parity data.

@Brandon.P is there a specific knowledge-base article somewhere that goes through this process step-by-step? Something written by someone who’s employed by Western Digital who knows how this works?

Here’s my bad experience.

I have DL4100 with three 10 TB red drives configured in RAID 5 volume sized 19.1 TB. It was 95% full so I wanted to add a fourth 10 TB drive and expand the RAID volume onto the new drive which should result in a volume size of approximately 29.1 TB. I added the drive, went to Storage / RAID / Change RAID Mode / Expand Capacity, selected new drive, and the status changed to “Expanding Volume” with a steadily increasing % complete. After 5 days, the status was 100% and then changed to status “Resizing”. The size of the drive remained 19.1TB. 60 days later the status is still “Resizing” and size still 19.1TB. When I SSH to the system, TOP command shows process “resize2fs -fp /dev/md1 28600297M” consuming 50% CPU. “df -h” command shows size still 18.1TB for /dev/md1. “mdadm --detail /dev/md1” command shows Array Size 29286720960 and Used Dev Size 19524480640.

I opened two tickets with WD support and sent them logs. They claim logs show expansion complete and I should restart the system. When I tried to restart the system I was stopped by message “System shutdown…prohibited when the following operations are in progress: … disk formatting, disk resizing…”. WD support then told me to pull the power cord. I did, and when system restarted the status still shows “Resizing”, the size still shows 19.1TB, the resize2fs process is again running at 50% CPU, and I see same output from df and mdadm commands. I tried to kill the resize2fs process and it restarts automatically. After 60 days, WD support has no recommendation how to resolve this problem.

I think I will be forced to reformat and rebuild the RAID 5 volume and restore all my data from backup!