How to enable Photoshop to save to My Cloud?

Saw one thread on this but no solution was shared there.

I have tried to map the network but in the browse, I cannot find My Cloud.

Must be something simple which I did not do on installing My Cloud at the start.


You can map a drive to a MCM share using either Windows Explorer (under tools > map network drive) or using WD Quickview. That should then give you a local drive letter which PS may be able to save to?

Many thanks.

Tried Quickview and got Network Error. See attachment.

What am I doing wrong here? Thanks.

You need to either make the share public, or connect using a different user name (the link on your page there just underneath the reconnect at logon tickbox) and enter the username/password of a user with access to the share if private.

Tried another user. Same error.

When I clicked on the diagnosis, it came out with this

My Cloud is connected to my router and my PC to the router.

What can I try next?

Many thanks for your help.

Why are you getting VPN errors? Are you using a VPN? If not try closing down any VPN software that may be running on your machine, even if it’s not connected.

Also it may be a firewall or anti-virus/malware program could be blocking your access to the MCM.

It sounds like something is basically getting in the way of your PC talking to the MCM.

Just to confirm the basics, can you actually access the MCM and the files on it if you go directly (browse through Windows Explorer and its network section)?

I use VPN now and then when the need arises. Have checked that the icon says VPN is not connected while doing the troubleshooting last night. Did that again this morning with no net connection. Same error.

I can get to the MCM via the shortcut I got when I first installed MCM - WD My Cloud Mirror Public Share. Just checked, that access is still OK.

Maybe something is not set properly in the SETTINGS - NETWORK. Everything is still as the default setting except IPv4 network mode as STATIC. Need to configure that page for this access to work?

Many thanks once again.

No, you should be able to access the MCM via SMB (or Windows network share) by default, and you can’t turn that off.The static IP address won’t come into it either for this.

Just to confirm, what is the IP address of the MCM, and the IP address of your router and also the machine that you’re having problems accessing the MCM from? Just want to confirm that they’re on the same network.

Also do you have anything else like anti-virus or firewalls on either your router or local machine which could be blocking the connection? If so temporarily try disabling them and see if the two become visible to one another (if so then a suitable exception rule would need to be set up).