How to change permissions on the whole drive?

Hi there guys, need some help here, hoping someone can assist me. I am on a Windows 7 Pro 64bit maching, and I am trying to restore an Acronis backup, that I backed up to my network attached My Book Live. I have the backup, in it’s original location on my network drive. I believe I am having some permissions/secuirty issues during the recovery process that is causing Acronis to show me the errors I am getting.

So, I am attempting to change the permissions on my network attached My Book Live. Below are the steps I am following, and the screenshots of the errors I am getting when attempting to do so.

I am going to my Network, and selecting the My Book Live:

6-26-2012 9-35-04 PM.jpg

I then click the Public Share folder:

6-26-2012 9-35-19 PM.jpg

I then right click on the Public Folder and click Properties, and then I go to the security tab:

6-26-2012 9-46-13 PM.jpg

I then edit the permissions of the folder to allow full control and I hit apply:

6-26-2012 9-30-46 PM.jpg

I then get the following error:

6-26-2012 9-31-06 PM.jpg

I hit Continue, and I get:

6-26-2012 9-31-22 PM.jpg

So basically, no matter what I do, I am getting access denied. Is there a way to fix this, or avoid it? Any and all help and advice is greatly appreciated. I am stuck and do not know what else to try.

One cannot adjust the permissions of files and folders through the Windows FIlemanager / Explorer options.

Permissions are entirely controlled by the MBL, and any attempt to modify the permissions thru Windows can lead to other issues such as what you’re describing.

So how can I change the permissions on the MBL? Please any advice or point in the right direction would be very much appreciated! :slight_smile:

You assign user permissions from within the MBL’s web setup when you create the shares.

Tony,

hope you can help.

Recently bought a WD MyBookLive 2TB. All working fine (only using public folders so far) until the other day when:

tried to access ‘Shared Pictures’ and got ‘access denied’. Tried many ways to access folder by changing permission etc, but ultimately got access denied. Tried to copy folder, and got ‘you need permission from Unix User\root’

This would suggest to me, I need to alter the permissions within the MBL. At this point I am struggling!

I don’t think this is something I can do from the web setting facility, as the permission for the shared folder is pre-set and not adjustable here.

Can you help with adjusting the permissions within the MBL, being mindful that I do not understand Linux/Unix ? at all?

Cheers.

pharaoh:  I cannot imagine why it’d be doing that.

Have you ever accessed the MBL through something OTHER than your windows PC?  

Like via NFS or AFP?

I have no idea what those are - does that answer your question? (lol)

I have recently done a firmware update, and did (naively) try and restrict access to the folder by changing the folder security properties within windows. I now cannot access the folder no matter what I try.

Don’t know if this helps in any way, BUT I have just been able to access the pictures from my mobile using WD 2go absolutely no problem!

Neither of my computers (both running 7/ 64) can access the folder!

pharoah,

   FIrst try disconnecting the share, and then reconnecting to the share from scratch.

If that still doesn’t work, then log in via SSH (lots of how-to posts on that subject) and execute the following command:

ls -la /shares/Public/

 … and post the full output here.

Tony - thanks for the reply - appreciated!

Please excuse my ignorance, but I am not sure what you mean by ‘disconnect the share…’

Executed command and got:

login as: root root@192.168.1.101’s password: Linux MyBookLive 2.6.32.11-svn70860 #1 Thu May 17 13:32:51 PDT 2012 ppc Disclaimer: SSH provides access to the network device and all its content, only users with advanced computer networking and Linux experience should enable it. Failure to understand the Linux command line interface can result in rendering your network device inoperable, as well as allowing unauthorized users access to your network. If you enable SSH, do not share the root password with anyone you do not want to have direct access to all the content on your network device.

MyBookLive:~# ls -la /shares/Public/ total 384 drwxrwxr-x 6 root share 65536 Jan  1 12:32 . drwxrwxr-x 6 root share 65536 Jan  3 13:03 … -rw-r–r-- 1 root root      0 Dec 31 14:31 .tickle drwxrwxr-x 2 root share 65536 Jan  7 10:11 Shared Music drwx-wx–x 4 root share 65536 Jan  7 10:01 Shared Pictures drwxrwxr-x 2 root share 65536 Jan  7 10:18 Shared Videos drwxrwxr-x 2 root share 65536 Dec 24 12:54 Software MyBookLive:~# MyBookLive:~# MyBookLive:~# ls -la /shares/Public/ -bash:

will shortly be in a position to reset/factory reset to see if that helps, cause I have nearly backed up all my files via WD2go.

Cheers

The factory reset has now solved the problem. Was able to transfer files from ‘Shared Pictures’ folder using ftp (WD2go was very slow), followed by quick factory reset - and hey presto: got access to folder again!

Thanks for help Tony.

Well, I can see the issue:

drwx-wx–x 4 root share 65536 Jan  7 10:01 Shared Pictures 

WRITE access was allowed, but READ access was not.  

Can’t imagine how that would have happened…

Should be:

drwxrwxr-x 2 root share 65536 Dec 16 08:15 Shared Pictures

1 Like

Thanks Tony.

Should a similar problem re-occur, your advise will prove very helpfull.

Respect!

Hi Tony,

I’ve got a similar problem and I did use MBL in Ubuntu linux via NFS. Now I decided to move back to windows, backed up my files on MBL, reinstalled windows and now can’t get access to some of the folders on MBL. Could you please help?

****** WARNING ******

Take my advice at your own risk! 

This is going to be disruptive, but it is the simplest, most reliable way to reset all the permissions back where they need to be with a minimum of fuss.

You might want to wait a few days to see if anyone finds flaws or issues with my suggestion and to post their own.

*************************

Log into the MBL via SSH.

Issue the following commands.

cd /shares/
mv * Public
cd Public
chown -R nobody.share *
cd ..
chmod -R 775 Public
chown root.share Public

 Now, log into your MBL via the web browser and DELETE all shares and recreate the ones you need.

Once that’s done, connect to the shares via your PC, and go into the PUBLIC share and MOVE the files back to where you want them.

Hi Tony,

Thank you for these commands.

I followed them all.  Everything seemed to be working fine.  But then I made a mistake.  (Well, a couple actually!!)

First, I named the file ‘Pubic’ (instead of Public when typing in the ‘mv * Public’ command).  Followed through with the rest of the commands as mentioned.

When I looked in ssh, all the folders were shown as expected (using the ls command).

Now for the 2nd (and a big one it is) mistake!  These are the commands i entered:

ND22TB:/shares# ls
Pubic  Test
ND22TB:/shares# cd Pubic
ND22TB:/shares/Pubic# ls
320GB  :2eDS_Store  Network Trash Folder  Shared Pictures  Software
500GB  :2eapdisk    Shared Music          Shared Videos    Temporary Items
ND22TB:/shares/Pubic# mv * ./Test
mv: target `./Test’ is not a directory
ND22TB:/shares/Pubic# mv *
ND22TB:/shares/Pubic# ls
Temporary Items

Basically, I wanted to move all the contents of ‘Pubic’ to ‘Test’.  It gave me an error of

mv: target `./Test’ is not a directory

Then I typed 'mv * ’

I then realized that I ‘moved’ *(everything) to ‘nothing’

When I typed in the ls command it only showed me the ‘Temporary Items’ folder and nothing else.

I used the df command to check to see if the contents were deleted and it gv m the following result:

ND22TB:/DataVolume/shares/Pubic# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md1               1968336   1109124    759224  60% /
tmpfs                    51200         0     51200   0% /lib/init/rw
udev                     10240      6656      3584  65% /dev
tmpfs                    51200         0     51200   0% /dev/shm
tmpfs                    51200      2560     48640   5% /tmp
ramlog-tmpfs             20480      4928     15552  25% /var/log
/dev/sda4            1941348672 1589090176 352258496  82% /DataVolume

The /dev/sda4/ contents seem to be there as before.

My question is, can I ‘undo’ this erraneous ‘mv’ command.  If not, is there a way to restore the data (which apparently is still there).  Please help!

BTW, I am keeping the ssh terminal open…just in case, by logging out or shutting down the NAS, it might delete my data!

Charles

UPDATE!!!

I sorted it out. 

I found out that all the files/folders (in the ‘Pubic’ folder) had been moved to the 'Temporary Items" folder.  I could not access it (change directories to a folder with a space in the name).  I did some research and figured out that in order to change to a directiry with a space in it I had to put it in between “” (cd “Temporary Items”). Once there I moved all the files & folders up one directory (mv * …/) to the ‘Pubic’ folder.  Then I moved all files/folders (mv * …/Test) to the ‘Test’ directory (which I had created in the MBL browser dashboard).  Checked the test folder on my Mac and I CAN SEE ALL MY FILES!!!

WAAAHOOOO! (reference to the movie I.Q.)

ANY WAYZ…

Thank You very much

TonyPh12345 !!! for this set of instructions!!!  Was a great help (inspite of a few tense moments and idiotic moves)!!  Now, I will try to see if I can restore my old WD My Book Live that I had taken apart.

Charles