Permissions problems

Hello, I need some help about this problem I have since I bought my MBL 2 Tb, two days ago. When I create a private folder in a share, just the user that created that folder can access it, none of the others, whatever rights they have. My “environment” is this, two Lions, one Snow Leopard (no zebras), Time Capsule and firmware updated for the MBL. I have to say that the issue happens since day 0, and in all the computers, I have tried every possible combination of users, rights, and so.

Thanks in advance.

Can’t offer a solution because I’m having the same problem myself.

You create a PRIVATE folder WITHIN a share?

Exactly how are you doing that?

I can’t speak to the exact situation of the O.P.  In my case I have a share that’s accessible from two accounts.  One account is ‘admin’ and let’s call the other one ‘X’ .  The admin account should have read/write access to everything in the share and the ‘X’ account should be readonly.  All subfolders are visible to ‘X’ as they should be.  However one subfolder is not even readable by admin.  I should mention I’m accessing this from OSX Lion.  If I go into terminal and do an “ls -l”, I see “d---------” for permissions.  Even as root, I can’t change permissions with chmod (I guess that sort of makes sense because the actual drive is managed by the MyBook OS).  As root, I can cd into that closed subfolder and see files, but the permissions are awfully strange.  From the OSX finder, I can’t see into that particular subfolder.


is a very special case.

TECHNICALLY, the OWNER can still delete or read the file, even with those permissions, and also change the permissions.

But of course, root can read or write ANY file REGARDLESS of permissions.

What are the permissions of the PARENT DIRECTORY?

It does NOT make sense that root cannot chmod the file.

The permissions of the parent folder are “drwx------”.  What makes it really odd is that there are several sibling folders which all have the correct permissions.  Just one folder in the list with this problem.

I didn’t wanted to mean PRIVATE, I was trying to say that, within a share, any folder I create with any user, is just readable for that user, no other users can navigate it, regardless of the permissions assigned in the configuration of the MBL. I have tried mapping the driver, and for seconds it solved the problem, but as soon I closed the FINDER the situation reappears. I have tried even a FACTORY RESET, with no success.

And the issue appears in Lion and Snow Leopard.

It probably won’t happen if you mount it via SAMBA instead of AFP.   Try that.

I tried, and no success.c

Well, I tried a total factory reset and setup the MBL just with the snow leopard machine on, and mapping the drive with SMB, and the problem persists. I am curious if we two are the only ones having this issue, but the lack of feedback makes me think that this is a rare event. Going for a refund at the shop?

I’ve reported this as a bug to Western Digital.  Since I encountered it well before any terminal peeking, it’s clearly an operational issue with the device.  The overall permissions regimen is pretty simple and it seems to me that the onboard diagnostic tools should be able to detect and repair the situation.  I’ll swing back by here and report whatever comes of it.

I reported it too the day that started the thread, and receive this answer

Dear Jose,

Thank you for contacting Western Digital Customer Service and Support. My name is [Deleted]

It seems as though you may need to allow access to each share for the other users, as I believe each folder may only have access available for the intended user.

You can apply the proper permissions through the Dashboard, under Users for each share.

User Manual:

If you have any further questions, please reply to this email and we will be happy to assist you further.

Western Digital Service and Support

Then I reformulated the question, probably I didn’t explained myself properly, but didn’t get any response.

Perhaps I am in a rush, but the product is still in the return window and the lack of a simple “solution is in his way” doesn’t help.

I have to say that own two MyBooks and I am very happy, because that I decided to buy this one.

Sounds like the rep at WD didn’t really take the time to understand your problem and simply gave you a rote answer.  Although I’m very interested in hearing what they have to say in my case, I’ve managed to come up with a short term solution.  Since my readonly share could access the folder in question, I copied the contents to a local drive.  Then I went in as root (using terminal) and managed to delete that folder on the Mybook.  Then using the finder, I copied the stuff back and it seems to be OK now.  That’s not an approach for the faint of heart, and WD owes us a little cleaner web interface for that sort of thing.

We are investigating. Will let you know.


Hello everybody,

I have the same problem, any solution yet?

Thank you,


Haven’t had a recurrence of it.  I solved it last time by digging in at a level most consumers would fear.  If you know about basic unix commands you can fix it.  I’m not going to write a cookbook here because the unwary could really mess it up.  I don’t think a system reset/restore is anything but a waste of time.

Ok - I went over this with our developers and they believe that this is working as designed. They tell me that this is the way AFP works. If you don’t agree, then give me specific reasons and scenarios what is wrong so we can look at it.