No write rights as admin on Public/shares folders


My PC- System: Windows 8.1, 64-bit. Issue: can´t  transfer anymore files to public/shares folders on my  WD-My Book Live. Neither via Wlan nor via Lan.  Windows Explorer offers no option to either delete or copy files on MBL. Public shares folders on MBL are only readable, not writeable for admin. Even using SSH access to Public Shares on MBL is not possible although I am registered as admin. Access not permitted. Hard reset already done. Any solution available?. Obviousely my admin rights have been messed up. How can I fix this issue?

best  regards, Franco

Do you encounter the same issue for other accounts? What about new (Dummy) accounts? If they work fine for writing/modifying files, then I would recommend a hard reset by holding the reset switch on the back of the unit. If this does not work, then the next step would be a factory restore ( WARNING: Data-destructive ) in order to address any possible conflict related to the admin account.


WD mybook  runned smoothly for a long time, Laptops, network players and android devices connected. via old WD to go, WD photos, and a file manager all worked smooth.

Problems start with a new android device and installing WD-mycloud. Gained acces, but cannot copy file. Now write permission (including change name and stroring new files) are revoked for all useres, including Admin.

Settings in users and in shares display the read + write permission. Flicking the setting does not help. Adding a new user with permission also does not grant the permission.

Rebooting from MBL and a power cycle do not cure this.

Read works OK, although not all users can connect via windows. All users can connect from android (WD2go, WDphoto, but not from file managers that previously worked).
Network players still get media served.

The big Q: how to restore write permission? Really factory reset? means I have to buy another drive to hold the data? really no other solution, anyone?

I’m in a similar dilema … things have been going smoothly for a year … all of a sudden I have lost access to public files as admin … apps and Windows 8.1 Explorer etc can’t access the data?