Admin account permissions issue

I am using a MBL 1tb trying to connect over a network with my macbookrpro with osx 10.7.2. I have only one share and one user - public and Admin. admin does have a password set

In finder I can see my MBL, open it, connected to public as guest and also as admin with password.

But I strike issues when I try and open Shared Video, Shared Documents or Shared music folders 

I get the following error:

The folder “Shared Videos” can’t be opened because you don’t have permission to see its contents.

I have tried creating other users with full read / write - same outcome.

Have tried from another MBP on the network, also restarted both computer and MBL multiple times.

Please help I can’t access all my movies.


That’s odd… What firmware is the MBL?

This is very odd.  You have stated that you have created other users and granted them full read/write access to the Public share.  It is not possible to alter the permissions for any user to the Public share.  That option is always grayed out.  All users by default have read/write permission to the public Share.  Can you explain in more detail exactly how you are doing this? 

I am having the exact same problem. I couldnt delete a folder it said the “owner” when you select get info on anything is “daapd”.  However, you cant change the “owner” or it will say you dont have permission to do so. I have tried to factory restore the 2TB MBL, but the owner is still listed as “daapd”.

I have read somewhere that there are “ghost users” like (daapd, guest, ftp, admin-dfalias-wd, admin) that are not listed on the dashboards user control menu. (REF: problem with WD MB Live’s web interface) As stated in the linked article, it seems to be a really big security risk to have all these users available for someone to just pop in and browse my stuff. I would really appreciate it if someone could help me make my MBL more secure and fix this “owner” user issue.

Also the folders and connection was very slow before i factory restored the MBL.

I am not an expert when it comes to NAS. I just bought the thing like a month ago. I love it because it streams my movies and tv shows to my xbox 360. But this new issue is just driving me crazy.

Computer: Macbook Pro 13" OS X LION 10.7.2

NAS: My Book Live 2TB

Router/Modem: 2wire AT&T U-verse

Please explain in great detail!

Thanks for your time,


Please be sure you are on the latest firmware for the MBL - It should be 02.10.09-124.  The various firmware updates that have become available have corrected many issues - especially some related to security issues with the Public share.

To update firmware - Open the MBL dashboard at http://mybooklive.local

Click on Settings

Scroll Down to Updates and open the updates section.

Check your firmware version here - if it is not 02.10.09-124 - then click on the check for updates button.

Follow the prompts to allow the firmware update to download and apply.

The MBL will restart.  The update process and the restart may take a bit of time.

Do not interrupt the download/update/reboot process.

Make sure you see a Firware Updated notification in the top right of the MBL’s Dashboard after the reboot has completed.


I have exactly the same problem now and this is just after updating to the latest firmware revision (will check exactly which one it is tonight).

The ‘daapd’ account has read & write permissions to the shared video, shared music and shared photos directories (all sub directories of the Public folder).

Staff and Everybody have ‘Custom’ as the permissions and cannot see anything in any of these directories. I can connect to the NAS as the admin account but still can access any of the directories.

Does anyone know what the ‘daapd’ userid / password might be (as default ?) I’ve tried everything from the admin interface short of settign it back to factory settings (dont want to lose my data).

Heres hoping someone has the answer ! Cheers :cry:

Regardless of whether I connect as guest or connect as admin - the permissions I am seeing on the subfolders of the public share are:

daapd   Read & Write

staff       Read & Write

everyone  Read only.

But above the list of permissions it says “You have custom access”.

If I create a file in one of the subdirectories - the permissions show as:

daapd   Read & Write

staff       Read & Write

everyone  Read & Write

And above the list of permissions it says “You have custom access”.

If I look at the permissions on the folders on my time capsule I see the following permisions:

(unknown)   Read & Write

staff       Read & Write

everyone  Read & Write

I would suggest checking that there is not still yet another firmware update to apply to your MBL.  Are you able to see anything in the public folder and subfolders if you connect from a Windows pc?  Based on the permission settings you have listed - you are connect from a Mac.


hi Scott,

thanks for your detailed reply, much appreciated !

I checked the firmware and I’m on 02.10.09-124

I’m going to download it again and try running the update a second time to see if it has any effect.

I did map the drive to a win7 box on my home network and the Win7 machine has access to everything.

I also run a Plex server on the iMac (and then hook to the Mybook live for the content) and it can still access the data and I can stream to the iPad just fine.

The only thing I cant do is access the folders from the iMac (or Macbook) to update or add content.

cheers !


Do you have more than one Mac (or just the iMac)?  Your permission problem sounds really strange to me.  Although I have other issues with the MBL when using it in a Mac environment - I have not encountered this particular issue.  I am on Lion 10.7.3.  I haven’t tested this with Snow Leopard because I don’t have a Snow Leopard Mac available at the moment.  Did you try contacting WD Tech Support?  Although it might be a bit of a pain - you might want to consider doing a quick factory restore.  You would have to copy all your data off the MBL to another drive before doing the quick factory restore - because the quick restore will lose all of your data.


I’m running a MBP with Lion and have a 2TB MBL with Public, Home, and Admin fileshares…

What seems to be happening here is a situation when you are logged into the MBL with another userid(‘Home’ for my example) and save or put something in the Public share, say MP3s for the iTunes server. Even though its Public it retains the userid of what you’re attached with… ie I copied a couple albums to my Public Shared Music folder using the open (no userid) access from Lion’s Finder/Browser and they work fine. On another day I happended to be looged in as ‘Home’ (a restricted fileshare) and decided to put a few more albums into the Public Shared Music folder. When I did this I noticed we could not see the newest albums from our other computer “you do not have access permissions to see this” or something to that effect. If I login as ‘Home’ I can see everything under Public Shared Music so at least I know what is happening. 

What I haven’t figured out is how to change the permissions all the way through the ‘Public’ tree access to RW or correct the albums/directories that I put there as ‘Home.’ Its been a long time since I’ve played in unix and don’t want to do a recursive command that may botch the MBL directory structure somehow.

Any thoughts/help appreciated.


I have a similar error message when i log onto my 2TB WD my book live NAS.

I recently upgraded my mac book pro HD with a complete new install, so thank fully my documents folder were symbollically linked to my NAS.

However, now when i go to log in, i get the same errror:

“The folder “Documents” can’t be opened because you don’t have permission to see its contents.”

At first i was a little wierded out by the ‘daapd’ user. Who the heck was that? the dude who sold me my drive? nope. Cause I did a fresh partition and install of the OS.

BUT I did login remotely via web WD2GO site AND i might add, i can see my documents just fine thank you. But try to connect LOCALLY on my home LAN, nada, nope, no thing…

WD please chime in and help your stranded deciples! before we go Judas on you ; )



this is my first post here. Got a 2tb MBL. It works great with win 7 32 and 64 bit. Mac and Ipad.


There does not seem any way to elegantly back up the contents of MBL to an external drive.

All the files are on the MBL, they can be read, added to, deleted, but when it comes to copying them to another external drive the permissions are screwed.

Also I cannot change the permissions or ownership of the files on the MBL.

I think the MBL operating system is Linux so unless you know this you have had it.

I was going to buy another one to mirror the two (I am paranoid about backups) (and rightly so ).

But the MBL would appear to be a low cost central storage for your data you have safely duplicated elsewhere and thats it.

Not a professional answer for  storage and backup of mission critical data.

It’s good, very good, but could be so much better, I wonder why not…

best of luck all.

My first post here too.

Just encoutered this problem and I managed to fix it by logging into the server as a Guest. 

• On a Mac I ejected the Public Share.

• Command+K to bring up your Connect to Server Window.

• Enter your server address: e.g. afp://MyBookLive.local

• Click the Guest instead of Registered user login.

I’m guessing logging in as a guest applys the correct permissions. I was able to copy files to my Shared Videos folder after this change. Before, as a registered user, I got the error message about not having the right permisssions.

Hope this helps.

I tried the last suggestion and even logging as Guest in my mac but didn’t help. I’m running OS X Lion. However, I fixed the problem by enabling SSH through the web interface: http://mybooklivedevicename/UI/ssh, then logging through the terminal into the shares, and apply 777 to all the public folder, this allowed me to modify all my files without any problem anymore.

Hope this helps.


Yesterday I purchased a WD My Book Live, and set up a number of folders and today find all folders with a daapd user as the only one with read and wright privileges. In contacted tech support and I was directed to restore the drive but when I ask will this happen again I was advised it was a complicated issue with Apple Lion’s operating system and it may occur again???

Does anyone have a solution other than Pako144 setting up SSH and working in the terminal, its just a little above my comfort level after reading the warning.

who is daapd and how do I deleat them as a user.

I hate to restore and have it happen again, I am just not sure I can trust the drive after today.

"Failure to understand the SSH protocol can result in rendering your network server inoperable, as well as allowing unauthorized users access to your network. "

I have a wdlive 3tb which has developed the same issue in the past few weeks and it is driving me MENTAL!

Contacted tech support a week ago but still havent heard back.

Everything worked fine in the beginning but suddenly i got denied access to the shared folders (even though they’re under Public). I have automatic updates turned on so if it’s a firmware issue that might have triggered the change, that might be how it happened. I am now on 02.11.09-053

I have 2 macbooks, one running osx lion 10.7.4 and the other snow leopard 10.6.8 and the issue is identical so i don’t think it’s Lion’s fault…

Also my samsung and LG home theatre systems can still play the files in the shared folders fine.

I never set up any usernames/passwords or the WD2go service, my macs always connect as guest and can still access the folders i created through the Finder but not the default Shared Music/Pictures/Videos

I also have that daapd user with the same permissions as stated previously but can’t even connect to the nas with the admin/admin login, even after resetting the drive.

I can’t do a quick or full restore either since i can’t get the data off to back it up first :frowning:

Another annoying issue i’ve had since day 1 is that whenever i click on the Users or Shares tab in the dashboard i get 

an internal server error and i am unable to view/add/change any of the relevant content.

If anyone has any ideas or updates on this please post!! Looks like quite a few people on here would be really grateful for it!



OK, still haven’t found a solution to the account permissions issue but managed to move my files out of the shared folders so at least i can try a quick/full restore now after i back them up.

So for anyone who is in the same predicament; download the movie database program “My Movies Free” from the app store and install.  Click on the ‘folder import’ button up the top, click on ‘folder’ again in the popup window and navigate to the ‘shared videos’ folder on your WDlive, which strangely enough displays all the files that i can’t access through finder fine?!  Now open a regular Finder window and navigate to a folder on the WDlive that you can access or create a new one and just drag the files from My Movies window into your finder et voila…

Hope it helps someone!


I’ve been helping a friend troubleshoot their MBL for a few weeks and found several threads here discussing this same issue.  Finally pieced all the information together to come up with a solution that worked.

Symptoms:  Friend was using Mac OS X Snow Leopard.  Both OS and MBL confirmed on latest software/firmware.  Drive that was previously fully accessible ended up with the Public folder accessible but clicking inside it: “The folder “Shared Videos” can’t be opened because you don’t have permission to see its contents.”   Drive was accessible by opening finder and using smb://drivename.local but not through the normal mac share method.


  1. Went to the web UI using http://drivename.local/ which redirected to http://drivename.local/UI/

  2. Added ssh to the url:   http://drivename.local/UI/ssh

  3. Checked the box to turn on ssh

  4. Opened a terminal window, connected via ssh using the UI-supplied password

  5. Navigated to the public folder.  Ownership of the public folder was “root” and group “share”.  Ownership of the problematic subfolders was “root” and group “root”.

  6. executed the command “chgrp -R share Public” to change ownership of all files under public to the “share” group.

  7. Closed terminal window. Turned ssh back off.  Drive behaves normally.

  8. Opened beverage of my choice.

Good luck to any who this might help, and to the WD folks who read this and can figure out why the group ownership went wonky in the first place!

1 Like

Pff, so not impressed with WD costumer service! It took them 15 (!!) days to reply and their solution was

a) try and reconnect through the OS (really??)

b) update the firmware (djeez, didnt think of that either)

c) do a full restore (great, that’s what i was trying to avoid, duh)

Anyway, by the time i read their email (and the previous post) i had already started the full restore. This eventually solved my dashboard errors and at first sight the permission issues as well (although that daapd is still there). I changed the acces level for ‘everyone’ and ‘staff’ to 'read & write" as well instead of ‘read only’ and started to fill my nas up again. Everything worked fine until this morning when i reconnect after transferring about 1,5TB of files overnight and i can’t drop any more cause the folder access has somehow gone back to ‘read only’ :frowning:

I’m about to try dbwiddis’ solution now but I’m getting stuck on how to connect exactly cause i have no experience with terminal, so can you please explain step 4 a bit more? Thanks so much in advance!

WDcat, just replied to your PM but will post general info here for linux savvy.

When you log in via ssh, you are in the user default directory ~

You need to change to where your public directory is.  I think (based on memory) that’s /DataVolume/shares (case sensitive) so you would, after the login prompt, type:

cd /DataVolume/shares

That should get you to the directory where the Public folder is.  You can use ls -al in that directory, and looking at various subdirectories (e.g., ls -al Public) to see what the permissions issue might be.  For me, Public had the right user and group, but some of the subdirectories had the wrong group “root” instead of “share”.

1 Like