Cannot delete files

I have copied files from Public Music and Public pictures on my Vista PC to the equivalent folders on the Public share of the My Book Live. In these folders were folders called Sample Pictures and Sample Music.  I cannot now delete these said two folders from the My Book Live Public share because of permissions problems. I cannot change the permissions on the files either. The files in the folders have ‘Special Permissions’ and I cannot change these from being Read. I can delete other files and folders from the Public share, just not these two folders. It must have something to do with the original file permissions of these files on the Vista PC. Surely, if files are copied across as read only, it should be possible to change this so that they can be deleted! The files were copied across using SecondCopy, I have a feeling that SecondCopy retains the original security settings and therefore the owner of the files and folders as well. As the account I am using to access the Public share isn’t the owner, I suspect this is the reason.

It has nothing to do with your NTFS (Vista) permissions.

The files on your MB Live are owned by the user that you used to log in either to samba or ftp to copy the them there, or if you had guest option enabled in samba and used the anonymous user they are owned by user nobody.

The owner of the files can also delete them. If you still can’t, log in to MB live via SSH (enable it first if you haven’t done so yet), go to the directory where the files in subject are and use the following command on them: rm -rf file  .

This will solve all your problems.

Thanks for your help. I enabled SSH using http://mybooklivedevicename/UI/ssh, opened an SSH session using PuTTY and went in and found the files and deleted them without any issues and removed the directory they were in.

One question, do you know how to change the password associated with the root account? It isn’t editable through the ssh page on the My Book Live Dashboard.

I think you can use the command


but I’ve never tried it

1 Like

woow, never tried using ‘passwd’ ? :dizzy_face:

I’m surprised.

Yep that is how it works. Just login with root, type passwd and you will be asked for the new password, twice.

Mint.  Thank you.  Now I can keep SSH enabled and it being protected from external hacking. At least the reset button only blanks the admin password and sets the root password to it’s default…  (Just in case)  …without performing a full factory reset.

As always, when logged in on the bash shell and under root then there be dragons slumbering. Wake any of them up and you may end up having to send your MBL back to WDC where the technical support people will copy all your music, films and games for themselves (LOL!!! Joke!), totally reset the NAS and set it back to you. That may also include any intimate photos and videos too!!!   LOL! :smileyvery-happy:

I tried using chpasswd buit it kept on telling me that the passwords file is locked. passwd worked.