Help With apache2 in Debian OS


#1

I have installed the Debian firmware due to no support for MySQLi in the WD version.f
Debian Firmware

I am trying to get apache 2 working and for the life of me i cannot get remote connections working. Works perfectly fine on LAN.
I have created a vhost.conf file and included it in apache2.conf

NameVirtualHost 192.168.1.111:8080
NameVirtualHost **.**.**.**:8080  //this is my public ip

<VirtualHost 192.168.1.111:8080 **.**.**.**:8080>
DocumentRoot /var/www/html/
<Directory /var/www/html/>
Order Deny,Allow
Allow from all
</Directory>
ServerAlias host
ErrorLog /var/www/error.log
TransferLog /var/www/access.log
</VirtualHost>

Apart form that and setting it to listen 8080 in ports.conf i have not modified any other settings.

I have ran the online nmap tool which shows an open port on the apache port.

8080/tcp open  http-proxy

I have run netstat which showed the service running on port 8080 and i have checked iptables for both router and cloud which show 8080 being forwarded to the could and port 8080 open on the cloud.
I really have nowhere else to look for a solution for this and have been trying every possible solution for about 2 weeks now.


#2

You’re probably better off posting on the Debian OS thread. After all, you’re not really using a MyCloud any more…


#3

I posted there almost a week ago, and on stack exchange and apachelouge over the past few weeks but im not getting any response from anyone. Or the only response i get is the default virtualhost configs (which i already tried)


#4

If it work in lan, maybe its a router problem? (Try DMZ-zone instead of port forward)