Apache Service failing

So it seems that the apache 2 service is failing in my drive within an ammount of time and that causes the dashboard and mycloud services to stop working.

I still see the drive mapped in the network (and can work with it) but cannot access the configuration, or from mycloud outside my physical network…

anyone with this problem?
(my cloud drive 4tb)

Are you stating you can not access the Dashboard when not on the local network. The Dashboard is only available on the local network and not from the internet.

I’m saying i cannot access dashboard on my local network
and cannot access the mycloud service once i’m outside the network

What OS are you running?
Does the light on the front of the My Cloud stay “Blue”?
What color, in the rear of the My Cloud, are the connection lights? (Green/Yellow) … Show activity?
Are you using UPNP on your router?
DHCP or Static IP on the My Cloud and router?

The more we know about your setup the more we can help … otherwise everything is just a guess.

Static ip assigned to the drive, outside the dhcp range (no conflicts with other devices)
Blue light in the front
connection lights in the rear, green (showing activity)
using UPNP on the router
Using windows 7

Have you tried leaving the My Cloud set to DCHP, then set the IP of the My Cloud, in your router, to an assigned IP within the DCHP server range?

By the way … are you using a GEN2 My Cloud firmware 2.xxx or the older My Cloud with firmware 4.xxxx ?

Firmware i’m using:

I really don’t think is an IP address problem. If it were, i woudn’t see the drive mapped in the network when the dashboard fails.

once i’m without dashboard, i’m still able to work with the drive or make ping to it.
so, no ip address problem there.

Have you modified the firmware in any way (typically via SSH)? Was this My Cloud one that was “unbricked” in the past?

Have you tried a 4 second reset via the reset button on the back of the My Cloud?
Have you tried power cycling the My Cloud and seeing if that clears the problem?

No i haven’t.
What i can confirm is that the problem is the Apache web server.
once I couldn’t access the dashboard or my cloud services (2 minutes ago),
i entered the device through ssh and restarted the apache web server.
and eureka, i have dashboard and my cloud services again.
there is something that is making the Apache web server crash.

Can you confirm the crash? When it happened and before you restarted the service, is the process still alive (not in zombie or D state)? Is the daemon port still listening? The logs could have hints. I’ve never encountered apache behaving like you’ve described except for slowdowns when there’s too much PHP request at once.

You could try updating the firmware again but I doubt it’ll help.

I’m updating this old thread since I’m having this same issue (apache2 seems to be failing). This started happening after the latest firmware update to my Gen 1 2TB MyCloud.

I can connect via SSH and Windows 10 network shares. Can’t connect to Dashboard or via MYCloud web site.(cloud access).

I’ve restarted apache2 (/etc/init.d/apache2 start) but still waiting to connect to dashboard after 5 minutes. At least the connection isn’t refused.

I could look in the logs. Just need to know the location. Just know enough linux to be dangerous. :slight_smile:

Also here is a thread I started the first time I had this issue. I usuallt just reboot, but would like to find a permanent solution.

I know it’s a late reply, but I have this problem and I have followed un-bricking instructions in the past, haven’t been able to get into the webUI since because of apache failing. When I manually restart it via ssh I can hop into the webUI, but I get all sorts of network/service errors like

Unable to retrieve data. Make sure there are no network connectivity issues and try again. (200005)

Unknown error. Retry your last operation. If the error persists, contact WD Support for assistance. (200000)





Any light you can shed on what I may have done wrong?

I think the problem all boils down to performance. If response is slow apache eventually aborts. Since I eliminated remote access and twonkey my mycloud has been flawless.

I’m sure that’s part of the issue, or the issue for some, but in this case
I’m certain that my image got messed up somehow. I upgraded from a 3tb red
to a 6tb blue It was good till I updated the firmware through the web UI,
and immediately apace crashes every single time. I have had zero access to
the dash since then, and if I swap the 3tb red back in it works fine. In
just curious why Nazar78 called the “debrick” out as a possible cause right
away since that was exactly when this started happening for me

I suspect that these devices and their software are specific to the actual physical disk somehow.

No I didn’t mentioned anything about debricking, just reflash the original firmware again. Then go to the Dashboard and perform a factory reset. And I was replying to the author of this thread but he didn’t reply further so no clue.

For your case, when you replace the red 3TB with the blue 6TB, was the partition (GPT) allocated and resized correctly? I asked because once I got my GPT corrupted and strange things happens. And for the apache errors, take a look at the logs (messages/user etc2 in /var/log/* not just apache’s), perhaps there’s some hints why it failed like OOO (out of memory).