Help ROLLING BACK firmware

I searched and found the HOW TO but I don’t have the options. 

Trying to follow this http://wdc.custhelp.com/app/answers/detail/a_id/5860/~/how-to-roll-back-the-firmware-on-a-wd-tv-live-hub-media-center-or-wd-tv-live%29

But as soon as I plug the USB, it says connecting to USB and that’s it.   it goes back to the home screen.

I don’t get the New Firmware option.

I want to revert back as since the lates firmware, 2.0??? is causing my machine to freeze a lot.

Any info  is appreciated.

Open the VER file.

Paste the contents in your reply.

I downloaded the 1.16 version but my ver file says this

VERSION=‘2.06.16_B’
LOCATION=‘wdtvlive2.bin’
PKG_LOCATION=‘wdtvlive2.pkg’
ROOTFS2=’’

Well, that’s a problem – that rollback firmware didn’t come from the page you linked above…

That VER file came from firmware for a “WD TV Live HD Plus”, not the “WD TV Live Streaming Media Player.”

The correct VER file for a 1.16.13 Rollback firmware would read:

VERSION='3.16.13'
LOCATION='wdtvlivegen3.bin'
PKG_LOCATION='wdtvlivegen3.pkg'
ROOTFS2=''

Downloading that one now.   the other one I thought was right.

thanks.

was fixed.   watched about 4 hours of TV and then it reboots and right back to the NEW FIRMWARE option.      I don’t have a remote an it won’t go to wireless for me to control it.

have to take the RJ45 cable and plug. too late in the day for that.

if I was to get another brand, what do you recommend?    this one is a pest to deal with.

Since you’ve downgraded you’re obviously getting the NEW FIRMWARE option as it is available online. You don’t need to update though and you also can turn off this message. However, what makes you think it’s a problem of the 2.01 firmware when you still experience it after your rollback?

I am starting to think it’s the machine that is flawed and not the firmware.

I rolled back as some experienced the same issues I had and that had fixed it.

thanks.

So, there’s something in your network throwing off the WDTV. Probably a master browser or upnp issue.

I turned off UPNP a while back.

last night, it worked intermitten.  It came back on my network via wireless without me having to connect it direct. 

this started before I changed my modem from Rogers.

no other changes were done on my network accept the new modem.   It’s worst with the new one.