Help - replaced corrupted raid1 drive on WD DUO, now files not visible!

Hey all, have a WD DUO with 2x WD Red 6TB drives in it. Last week it went offline one of the drives started making making a clicking noise. So I bought a new drive replaced the broken one and ran rebuild through WD Drive Utilities.

It took about 24hrs. Now shows up as RADI 1 as “healthy”. And both drives as “online”.
Ran all three tests under Diagnose and all three show up as “passed”

BUT - I can’t access the files. It doesn’t show up as mapped any more.
I ran Disk management and mapped to D:/ but any time I click on the drive it says I need to format the drive before use, and “the parameter is incorrect”.

Obviously I don’t want to format the drive as I have close to 5TB of files on there.

I followed the instructions exactly, is there anything I can do to access the data again?

P.s. I ran a test of easeUS and it can see there is data on the drive. But don’t want to go through a recovery software, replacing a drive on raid1 shoudl work right?

Would really appreciate any help. Thanks!

Hi @AlexW8,

Thanks for reporting the issue.

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for best assistance and troubleshooting:

Yup I did. And the response I got was to format the drive and loose all the data. So I’m looking at other more helpful alternatives.