HELP! PROBLEM: My passport Ultra unlocker can be opened but the drive after unlocking cannot be opened and windows explorer malfunctions

Hi, I’m having problem with my passport ultra. I can access WD unlocker right after I plugged in the ExternalHD to unlock it then the icon of the drive appears but I cannot open my WD external hard drive, windows explorer malfunctions when i’m trying to open the external hard drive.

  1. I tried opening WD Drive Utilities and WD Smartware, Both can detect the WD unlocker but when i tried to unlock it by using both Utilites and Smartware It says that the password is not correct, when i tried unlocking the drive then opening the Utilities and Smartware both cannot detect the drive.

  2. I tried other laptop but the problem still persist

  3. I wanted to try to use chkdsk to fix if it is just a corrupted data but i don’t want to take risk to let the external drive to be plugged in overnight because of the chance that the hardware may be the problem because I have a huge files and also important files on it.

What seems to be the problem of the External HDD ?
Is there any chance that its problem is just a corrupted data?
Can it still be fixed ?

Please Help. Thank you !!

P.S : Before the external hard drive had this issue I was using it and it is working fine, I checked my recycle bin and I’m trying to restore a file(I don’t know if it was from the file of the external hard drive), it did not restore, so i tried to just erase all the files from the recycle bin and i also tried copying a file from the external to a flash drive then my OS(Windows 8.1) just malfunctioned(Not a bluescreen, It just turns black but I can still access control-alt-delete options) so I plugged out the External Drive and Hard reboot the laptop then I tried to use the External drive again and this problem occured.

As I posted in your other thread: It all points out to data corruption or a volume failure. I’d recommend testing your hard drive using WD Drive Utilities. If the unit passes all tests then it should be formatted. If the unit fails any test then it should be replaced.

Thank you for your response ! :slight_smile:

The thing is that i cannot use WD ulitities because when my drive is locked and i’m trying to unlock it using WD Utilities it says that my password is incorrect but when i successfully unlocked the disk drive using windows explorer, the hard disk cannot be detected by WD Utilities.

Is that the only way for my HDD ? Is there any other method to try recover some files from it ? I really needed some files on my HDD

Hi all…I just replaced my trusted WD passport (it started clicking and I cannot get to my data any longer) with a new WD passport ultra. Compared to the old passport this is a bit of a pain in the neck… The drive has backed up my selected files, but I spent hours trying to get to the backed up data… Cannot get quick view to work at all BUT I DID FIND THE BACKED UP DATA!!! Here is how:


1 Like

Can you unlock the hard drive using WD SmartWare instead of WD Drive Utilities?

It’s actually the exact same structure as with WD SmartWare. The difference is a visual interface, but files for both apps are stored with the exact same structure (Which happens to be the structure of your C drive: Computer> Volume> Users> Your Username> Data).

THANK YOU, gfellmayer! My direction to the saved data was a bit different from yours, obviously due to differences in our computers, but thanks to you, I knew I could get to it and I found it and recovered my precious data. Progress from WD or not, you helped me find what I so desperately needed and was irreplaceable. I’m thrilled!!