Help needed with problems accessing MyCloudEx2 after Windows 10 clean install


#1

I am tearing my hair out after I had to do a clean install of Windows 10 with the connection to my MyCloudEx2 NAS. I have two issues:

  1. While my other network attached devices are listed under ‘Network’ in Explorer, the WDMyCloudEx2 is no, longer visible making it difficult to connect to the NAS after starting the computer - the MyCloudEx2 continues to be listed under ‘Network’ on my other Windows 10 PC.

  2. There are stability problems with my ISP at present requiring a reset of the modem / router after a problem occurs. Each time this happens the NAS maps to a different IP address, as a result my mapped drives no longer work and I have to go through the whole procedure again. Again this is problem does not occur with my other Win 10 PC which seems to be able to switch to the new IP address without a problem.

I have tried setting the MyCloudEx2 to a static address, but after it rebooted I lost all connection to the NAS, despite using the existing IP address, necessitating a soft reset of the MyCloudEx2

I have also tried setting the NAS to a static IP address in the modem, but I must be doing something wrong with the settings as it doesn’t accept the IP, subnet mask or gateway addresses.

I’ve never had this sort of problem before and not sure that is causing it and would appreciate any assistance on how to get the MyCloudEx2 to show under ‘Network’ and how I can ensure that, if the dynamic IP address changes, Windows 10 links to this without me needing to reinitialise the NAS and remap all the drives.


#2

Hi exspextations,

I would suggest mapping the shares by using the name instead of the IP address as if the IP changes, it will not disconnect your mapping.
Here, the default name of the My Cloud Ex2 device is “\WDMYCLOUDEX2” if not changed. You can refer below article for more details.


#3

I had a similar problem with network devices; for me it turned out that I was using two different “work group” names. This didn’t prevent access; but did prevent devices from being visible in the file explorer “network” section.

That would not affect the IP problem, however…


#4

Hi Brandon.P,

Thanks for the tip - I’ve changed all the mapped drives to \WDMyCloudEx2\share_name and this seems to have worked when I deliberately changed the IP address of the NAS.


#5

Hi NAS_user,

I have checked the Workgroup name of the two PCs linked to my home network - both use the Windows default ‘WORKGROUP’ - so that doesn’t appear to be the problem.

However, both PCs show up under Explorer ‘Network’ when running, as does my WiFi networked printer and the share associated with my modem/router. I think something else is causing the problem.