HELP - My Book Live Duo not accessable any more

Hello everybody!
I am really screwed - 20 years worth of photography are on my My Book Live Duo which was set on Raid 1. And now hard drive A seems to be defective making strange noises, and the enclosure itself is not accessable anymore just showing a yellow light in front of the enclosure. I did not manage to get a Connection via Network or USB. Just seems to be unaccessable. Tried with both hard drives on, and also removed the defective hard drive A. No luck.

Already tried different other things: just hooked hard drive B up to my Windows 10 Computer where I installed Linux Reader 4.0.23. The hard drive is visible as “Linux Ext Volume 1”, where some date can be accessed - but no photo files visible there.

There are also two Raid disks visible, myBookLiveDuo:2 and :3. But they are not accessable, saying RAID is damaged but recovery is possible.

Can somebody help me?? PLEASE?? I am really screwed otherwise…

Thank you so much and stay healthy!

Andreas

anybody??