Help! How to recover a deleted share?

I was just trying to delete an unwanted default “admin” share, but strangely after selecting the share and press “delete” and “ok”. The “admin” folder is still there, but other folder beside it disappears!!! This is really very strange and disastrous!!! I am one hundred percent certain that I did select the “admin” folder before proceeding to delete it. The data in the disappeared share is very important to me. I tried reboot and restore to system default, all in vain. I have removed the disk and connect it via usb to a pc and have tried data-recovery software . But after hours of full scanning, I cannot find the original share any more. Only the system files, with the current share folders and some strange partitions with empty folders or a few names of files that have been deleted long time ago. I did find a strange file with the same name of the deleted share within the system’s share folder. But it is a only a file containing some strange binary code and cannot open as a folder. I don’t know what WD My cloud actually do when deleting a share folder. Does it erase all the data immediately? (the deleted share is about 30 gigabytes in size) Is a share folder treated as a partition of the disk or just a folder? What shall I do now??? Please help me!

Hello and welcome to the community,

Since recovering your files is important I recommend you to contact tech support directly before trying anything else.

Contact WD

This actually happened twice to me recently. At first I thought I was to blame for mistakenly selecting the wrong share folder to delete. And when I phoned the support, he simply said there was no way it could be undone. Now this time I am 100% sure that I selected the correct share fold before deleting it. Still it deleted wrong folder. BTW, I don’t remember exactly how it happened last time, but this time before the deletion, I had changed the default admin name to my name and then decide to delete the new default ‘my name’ share folder, that’s when the wrong deletion happened? Were they related? Is this perhaps a defect of the drive’s system/firmware (v4.1) ? Thank you.

1 Like

I was able to recover some documents using Recuva but the fold structure has all been lost as the original file names.    It’s all a mass.    Rethinking what has happened, I think WD My Cloud has some serious flaw in its product and interface design.    Firstly, if one intends to temporarily disable the sharing of a folder, he has no other way but to “unshare” the folder which turns out to be “deleting” the folder and its files all together!!!  I really don’t see the necessity of deleting the entire folder immediately just to unshare it.        Secondly,  for such an important operation (unsharing means deletion), there is NO confirmation of the name of the folder about to be unshared/deleted.    Before you press ok to proceed with the deletion, there is only a message asking you whether you want to proceed.  NO name of the folder to be deleted is displayed.    That would turn out to be a huge problem given the fact that the folder one selected previously might not be the folder WD My Cloud will actually delete.  One cannot be 100% sure which folder My Cloud is deleting.   That is devastating.  What happened to me twice proves this.   I believe this is not due to a defective product of mine, but a serious failure in the design of the product (firmware).