G technology Shuttle XL won't turn on

Woke up this morning with and issue on my G shuttle XL, it simply won’t turn on, I have done the following:

-Change thunderbolt cable. (Tried the cable on another G-drive and it did power it up)
-Change power cable (Tried the cable on a different appliance and it did work)
-Change thunderbolt to usb-c Adapter.

Help please!

Things that come into my head, possible update that ■■■■■■ something up.

Is this a Thunderbolt 3 device or Thunderbolt 2 unit? Thunderbolt to USB-C is technically not a thing that can be done since they are different interfaces so we need to make sure what you have and how you have it attached for certain.

You can also contact our support directly: Contact Phone Support

It is thunderbolt 2 to USB-C //

Will try on a thunderbolt to thunderbolt port and let you know.

Can I call from Central America?

Rydia, I already tried with a direct connection via thunderbolt 2, nothing happens on the unit,

Is there any step I could do to check anything else, seems like is not powering up…