G Tech Graid 4 TB , one drive spins the other one doesn't. No front white LED

I have recently bought a used 4TB G RAID drive. It was working fine initially. When I plugged it in the other Mac Pro (running Big Sur), a warning sign popped which unfortunately I can’t remember. I ran drive DX and it showed 90% health of the top drive and 75% for the bottom drive. I then ran first aid via disk utility and it said the drive cannot be repaired and came up with exit code 8. I then re-ran disk utility a few more times and suddenly the drive switched off. I tried to turn the power on the GRAId but no affect. I then let it sit for half an hour after plugging back the power adapter, I turned on the power switch again. The front white LED started to flash but no drive spin. I then bought a new power adapter (12v, 4A) with no effect. I then tested individual drives into external enclosure and they seemed to be detected by Mac Pro. I put the drives back in, now the bottom drive spins, but the top drive doesn’t spin. There is no front white LED either. Despite one spinning drive it is not dected by Mac Pro.
Can anyone guide me if the problem is with the drives or with the enclosure.

Your help will be much appreciated

Many thanks in advance.

I additionally went confronting a fundamentally vague issue at any rate whatsoever point it is agreed to me. Much appreciation to you for the help. OfficePoolFootball

bought a brand new usb G Raid dual drive 8TB and it has failed repeatedly since day one, bricked at least 4 drives… it is a horrendous piece of cr@p. POS. NEVER got any help or assistance from GTech much less western digital. these drives are sh*te.