G-Speed Studio XL crashing Mojave

Late 2015 Thunderbolt 2 G-Speed Studio XL 24TB. was working perfectly. Upgraded to Mac OS10.14.1 Mojave and OS crashes if G-Speed is plugged into thunderbolt port.

What type of Mac are you using? Since you just updated the OS you could try resetting the SMC and NVRAM to see if that fixes the issue. There are no drivers for the TB2 model so it would be a reaction to the drivers built into your OS.

It’s a late 2015 iMac Retina 5K, 27 inch. I have managed to re-install OS10.13.6 and everything is fine again.
Thank you Apple. (: Not!!

I have this same issue. My G-Speed Studio XL causes kernel panics on Mojave, randomly. I even tried a clean install of MacOS on two different computers, still causing kernel panics. Is G-Technology aware of this and will there be a fix?

I tried the raid on two different machines running Mojave. Kernel Panic on both. Reverted to High Sierra and all runs fine.
Time to catch up G-Tech!

Looks like G-Tech are ignoring this issue, sadly.

So six months later there is still no response from G-Tech! Cannot risk upgrading to Mac OS 10.14 as there does not appear to be an updated package from G-Tech.

There is no need of an update, there has been no issues we have been able to re-create with 10.14. There are updates to firmware and the GSU when necessary through the app.

Thank you for your response. When I updated to 10.14 the Mac had repeated kernel panics when the raid was attached. I had to downgrade to 10.13 to clear that. Are there firmware and GSU updates which need to be performed before updating to 10.14?

No, there is nothing required to be ran prior to Mojave.

I just got a new iMac 27 that came with Mojave. Everything works fine until I plug in my G-Speed raid array. The iMac just freezes up.

Is there still no update?

I finally found the new driver for TB3 in the downloads page and that seems to have fixed my problem.