G-speed shuttle xl thunderbolt 3 device not found

i INSTALLED DRIVERS FROM G-SPEED TB3&TB2 Shuttle WinDrv_Installer_V6.2.0.6_WHQL-8
Rebooted and connected the drive.
Installed G-SPEED_Software_Utility_200520028
I can’t see the device in create and format partitions,
The device cannot be found in G speed software utility
I see the device via intel thunderbolt software ver connected at port 1
and the device show up G-Technology, G-SPEED Shuttle XL Thunderbolt 3
All the disks have heavy activity.
P.S. Is the first boot of the unit.
Please help.

As long as you have allowed the device in the TB software from intel it should be able to pass through. Make sure the intel software is the most recent version as well from your motherboard.

Check Device Manager and see if it shows any devices needing drivers, sometimes you just have to go to the storage controller that is waiting there and force it to look for drivers and it will find the ones that are there. Otherwise you point it directly to the drives in C:\Program Files (x86)\G-Technology\

Hello and thank You for the Quick reply.
I have latest version for Intel Thunderbolt driver and motherboard BIOS (Asus x299) i have latest drivers from g-tech and latest applicati in version.
Do You have any more suggestion?

Searching in the forum i found another thread with the same problem, how did You solved that problem?

As you can see in that response it wasn’t solved on the forum and we had asked them to contact us.

The final mention was the same I had given you which was to check the device manager for missing devices to be installed/updated. You didn’t respond to that mention other than to say you had the latest intel drivers.

Please call in to our support for a more direct hands on approach. 888.426.5214 of US support.

Same issue here…