G SPEED Q Configurator Issue

I use an old G-SPEED Q 4x3 TB eS drive which I’m currently using as USB drive. The drive is fully functional and it’s on RAID 5 but I want now to change it to RAID 0.Therefore I was trying to use the G-SPEED Q RAID USB 2.0 Configurator on Mac using macOS Sierra (10.12.6). When trying to launch the G-Tech Configurator app it crashes with

libc++abi.dylib: terminating with uncaught exception of type int

libc++abi.dylib: terminating with uncaught exception of type int (1006

I tried this software on two different Macs both on macOS Sierra (10.12.6). No Success.

I also tried G-SPEED Q RAID USB 2.0 Configurator (32-bit) on Windows 10 and on Windows 10 the Configurator is searching for the mounted G-SPEED Q (I reformatted it to Windows NTFS) but the app seems to hang, at least it never pops up the configurator window as it stuck at the “Searching for G-SPEED drive” screen.

What else can I do to config my G-SPEED Q drive?


You mentioned 2 different products in your device name.

We have a G-Speed eS and a G-Speed Q. Which one do you have? If it is the Q and you have it attached via USB, is it the USB 2.0 or 3.0 model? We have a configurator for each. However these configurators have not been updated since 10.9.x so you might run into compatibility issues.

One thing to do to help is install Java on your system. If you have Windows than that is an option as well, it doesn’t need to be formatted prior.

Sorry. It’s clearly a G-SPEED Q and it’s a USB 2.0 model. Of course I installed legacy Java 6 but this does not matter. It does always crash.

Meanwhile I installed macOS 10.9 (Mavericks) and also tried 10.7 (Lion) in VMware and started the G-SPEED Q on both VMs but it crashes there as well.

As I said I tried on Windows too. It has Java installed but the configurator app does not find the G-SPEED Q drive.

It’s so frustrating that such a great storage is totally out of support. Is there any way to provide other tools to reconfigure the RAID? What are the difficulties to get rid of the crash? Can you please verify on your side that the configurator app does work (Windows/Mac) with a G-SPEED Q, connected via USB 2.0?


I have exactly the same issue, did you find a fix?

I’m shocked that there would be such poor support from GTech!

Yes, I was able to fix it as I do still own an old Mac Pro Silver Tower with MacOS X 10.9 (Mavericks) which I have not used for more than 5 years. I did not expect it would ever work but I connected the G-SPEED Q via USB and downloaded the latest configurator software which found the drive and I was then able to change it to RAID 0.