G-Speed Q configurator utilities hang up. Not working

I’ve been running 4 G-speed es drives via RAID card on a Lenovo / Intel i5 CPU on a 64 bit bus / 16.0 GB Ram running Windows 7 for ~5 years with great success. I also have a G-speed Q that I ran successfully for about 2 years.

However, I just upgraded the G-speed Q with 3TB drives (12-TB total). I installed the new (HITACHI 0F12456 Ultrastar A7K3000 3TB 7200 RPM 64MB cache SATA 6.0Gb/s 3.5 internal hard drives). I am trying to configure the G-speed Q for RAID 5. The program hangs-up (freezes, just displays the splash screen. I have tried both of the versions listed below to no avail.

I have 2 other Lenovo 64 bit PC’s running Win8. I tried setting the G-speed Q up on one of the other PC’s as well, so it does not appear to be my office PC.

I have tried G-SpeedQ_RAIDConfigureUtility_v0_2
I have tried G-SPEED Q RAID USB 3.0 Configurator (64-bit

Any Help would be appreciated. Let me know if you need further information.
Thank You,

Here is a snip of the splash screen.

Hello Ron,

I am sending you a PM to make sure we can track the software configurator you’re using.

I hope this is what you need.

I really like the Q model and hope that I can get it upgraded with the newer/larger Disc’s. With the builtin RAID, seems that it would be an easier method of retrieving archives in-case of a PC melt down. Theoretically, I could have the program installed on all three of our PC’s and then I could just move the Q to another room in the house.

Here are the two config programs I have tried.

Let me know if you require more info.

This drive is non-respondent. There is a RED light next to the Triangle on the front of the drive. Is there a way to Reset or Flash the drive ?