G-RAID 2 problems

I am completely new to G-RAID 2 having just purchased it. I was able to get it connected and it was working, but due to my over experimenting I have messed it up.

As a result it was degraded, one red and one blue LED! So I reconfigured it from RAID 1 to Raid 0 with the intention of configuring again back to RAID 1. This is where it all went wrong and not the Mac does not see G-RAID 2.

So I followed the following course of action:

  1. Closed everything down and switched oo.

  2. Restarted the MacBookPro

  3. Switched on the G-RAID 2, but not connected to the MAC with USB lead.

  4. The G-RAID displayed one red and one blue LED.

  5. Connected the G-RAID to the Mac

  6. Got message Disk Attached not readable by Mac and I was presented with the option Eject, Ignore or Initilise.

  7. I selected Initialise and the Disk Utility program opened

  8. I ran First Aid and it reported Operation Successful.

  9. I ran Restore and it reported Not Validated Operation not permitted.

  10. I finally ran Erase and it failed.

  11. I also tried the G-Raid and Thunderbolt App which was fruitless.

I think is mess is really my own doing so any help would be much appreciated.