G-Drive USB formatted as EXFAT cannot be mounted in Mac OS High Sierra

Hi,
I have a 10TB G-Drive USB (not USB-C) harddisk and I have formatted it to ExFAT via a Window 7 PC.
It works fine with the PC.
I later on bought a new mac book pro with touch bar with macOS High Sierra 10.13.3,
and found out that the G-drive is not mountable by the mac book.

I can find the hark disk in disk utility with the correct name but the harddisk name is greyed and do not allow me to mount it. First-aid was done and it was fine.
The hard disk is not corrupted as I can still use it with PC.

If it helps, I am using an adaptor to convert the usb 3.0 cable to usb-C for the macbook.

I would like to know how to solve the issue as I need the harddisk to be used in both PC and Mac, so I need it to be ExFAT.

Thank you very much!

In some cases exFat formatted drives won’t mount on the Mac OS due to slight corruptions that it feels prevent it from mounting. You can either run a repair on the drive on Windows or use a terminal command on Mac to rebuild the directory.

On Mac in the terminal you can do the following:

sudo fsck_exfat -d disk*s*

Replace * with the drive numbers as shown in disk utility.
When it prompts: Main boot region needs to be updated. Yes/No? Type yes.

Thank you,

I did what you said but i still cannot mount my drive.

** Checking active bitmap.

Checking bitmap cluster 2

Read offset = 0x000001000000 length = 0x400000

0 clusters were marked used, but not referenced

0 clusters were marked used and CLUST_BAD

0 clusters were marked free, but referenced

** Rechecking main boot region.

** Rechecking alternate boot region.

** The volume AK Library appears to be OK.

Both Windows and Mac OS said no problem found from the disk.

when I tried to mount it,
mount: disk2s2: unknown special file or file system.

this is what i get when util list

/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *10.0 TB disk2
1: Microsoft Reserved 134.2 MB disk2s1
2: Microsoft Basic Data AK Library 10.0 TB disk2s2

If you get that message about an unknown file or file system that means it likely wasn’t formatted in exFAT or that it is beyond regular repair.

Your option then is to try using data recovery software to get beyond the corruption and retrieve whatever files you can and then reformat the drive so it can be used.

I had this same issue…and tried a lot of the prescriptions out there: manually mounting the drive through terminal, repairing the drive through Disk Utility, etc…but was never able to get my drive to mount on a mac. In the end I copied my material to another drive, reformatting the original drive exfat on a Mac, then copying the original material back over (which I realize with a 10TB drive is not ideal or maybe not even an option…).

In the end I found out that if I format my drives exfat from my pc with an allocation size higher then 1024 kb the drive won’t mount on a mac. 1024 kb and lower and the drive will mount right away.

I checked formatting exfat from a mac and it defaults to allocation size of 64kb.

Maybe this is common knowledge to people? But I haven’t been finding much info out there on allocation unit size limits for exfat on mac.

If anyone else knows another workaround to this or knows more about this generally I’d be interested to hear it.

Replying in 2020 here and cjcapes03, you are the man (or woman)! My new 5TB easystore WD drive formatted on the PC in eXFAT with allocation at default (which i believe was around 2048ish kb) would not mount on my mac for the life of me. I yanked it out and reformatted again on the PC but at 512kb allocation and bam! It mounted right up on the mac! Thanks again cjcapes03. I scoured many articles and forums with lengthy and complicated explanations that didn’t help one bit. Your simple solution was the answer!

Exfat Recovery

The way I found it was very simple.

  1. Once there is a partition error, do nothing (don’t touch the partition to try anything). Remove the head after shutting down the computer.
  2. Find a computer with Windows 7 or higher around it.
  3. Connect to Windows PC.
  4. Do not be disappointed when the drive is not partitioned even if it is recognized, but open command prompt (with administrator rights)
  5. Run chkdsk /F d: (d: is the drive letter name).
  6. Then he’s surprised to find the extat! Name the disk volume! I’ll restore it! Find all the partitions and fix them on your own.

Because of this, I put down all the partition restoration tools or file restoration tools and made a fuss.
After all, I was desperate to restore the file. I’m sure it’s a partition problem.
It was so easy that I was dumbfounded. It’s working fine now.

Finally, although the opinion is often raised, extat still seems to have a lot of problems with Mac.
People who keep important data will need to be careful.
Then I hope it helped you.

If your ExFAT drive is not mounting, here is the solution.

sudo pkill -f fsck

fsck was holding the disk hostage. A quick ps aux | grep fsck revealed that indeed it was hijacking the disk/volume as soon as it was plugged in. sudo pkill -f fsck (or just kill with the PID if you prefer) immediately allowed the volume to be mounted.

Your drive will then mount, you can then use a SOS to fix it with Disk Utility. It will be mounted and readable again.