G-Drive is on but not recognized by mac

I have been using my G-Drive with thunderbolt 1TB drive for over a year now and have had little to no issues, but today i tried plugging it in and the drive lit up, but the device would not show up in the finder. All the support I have read seems to be geared towards people who have never used the drive, but I just started having this issue and I do not know what to do. I have a lot of files saved on my drive, and I really do not want to lose access to it. Help would be appreciated.

Hello Zombiezrppl2,

The description of your issue could be related to Directory corruption a common occurrence if the drive suddenly loses power or connection to the host during a read / write. Your first step would to be check the drive using Apple’s Disk Utility first aid. If your not familiar with using disk utility you can contact our call center. They can help walk you through Disk utiltiy and / or recommend the next steps to attempt retention of your data.

I am having an identical issue and looks like I will have to do a recovery. I’ve tried all the trouble shooting recommendations- but so far nothing. Apple was very helpful in assisting with the trouble shoot- but looks like I have a failed drive. I have used this as a BU to my MAC and had no warning to BU the BU. Never had to have a drive recovered- anyone know the success rate? Have multiple photographic and video files I’d like to recover. I’m in Austin - any recommendations on companies that are good at this?- Thank you in advance- Ann

Hello Ann_Smith,

If you believe your drive has a hardware issue you can visit the link below for a list of our Data recovery Partners that offer discounts to G-Technology Customers. If you like you can also call our support center depending on the type of failure we might have some suggestions for recovering data via software solutions.

G-Technology Data Recovery Partners: