G-Drive not showing up or backing up

My G-Drive stopped showing up in Finder and when I manually tried to “Back up now” on my Mac, I got an error saying it could not be found. I ran first aid in disk utility (where it does show up), and now in Finder I can see “Install Google Drive”, which shows all the content of my G Drive, but Time Machine still does not recognize it. I can’t find any option to actually re-install the G-Drive or anything, so I don’t know what to do next. Ideas?


What you’re experiencing is a corrupted partition. Install Google Drive doesn’t seem to be related to our devices as we don’t have anything to do with Google. However if the drive is being mislabeled it would be related to the corruption.

When this occurs and it will no longer mount you have two options. If First Aid doesn’t work then you can use a more powerful utility to repair/rebuild the partition. We highly recommend Disk Warrior for this.

If the data on the drive is not important and is just a backup and you don’t mind starting over then just select the drive in Disk Utility and Erase it. That will clean off any corruption and allow you to use the drive again with Time Machine.