Full Digital Audio Pass-through via HDMI (No Decoding on WD TV)

Hello all,

I searched around multiple forums and have not found information regarding this issue.  Is it possible for the WD TV to do “no decoding” and just pass all the audio for the AV receiver to decode?

Issue: there are some videos (mkv) with Dolby Digital 5.1 audio tracks.  There are a few that produce no sound or down sample the sound to 2.0 stereo.  The rest of the videos appear to work fine.  Thought it was just an issue with the audio track for those particular videos.  But, the same video worked on a Roku with sound.  The Roku performed a full passthrough and the AV receiver decoded the audio track fine.

Can the WD TV do the same full passthrough?  Don’t like the option of hacking the WD TV, but is there an option to do that and force it do to full Passthrough and let the AV receiver handle the audio decoding?

Tried the same video on WD TV Hub, WD TV SMP and the recently released WD TV.  None of these can play the audio correctly for those particular videos while the Roku can.  I would prefer to get this working on the WD TV.

The AV receiver is an Elite Pioneer receiver.

Thanks for the help.

I also have two different Pioneer receivers (none of them Elite, though) – I’ve never seen the WD do ANY type of transcoding for Dolby of any form for Dolby.

All of them are passed though natively via HDMI in my setup.

I’ve tested videos with

AC3 2.0

AC3 2.1

AC3 5.1

Dolby Digital Plus

Dolby True HD

Dolby Digital Surround EX

PureUncut wrote:

Issue: there are some videos (mkv) with Dolby Digital 5.1 audio tracks.  There are a few that produce no sound or down sample the sound to 2.0 stereo.  

Please post the full TEXT output of MEDIAINFO for such a file.

http://mediainfo.sourceforge.net

Hi,

Below is the media info.

Format : Matroska
Format version : Version 1
File size : 4.37 GiB
Duration : 2h 1mn
Overall bit rate : 5 150 Kbps
Encoded date : UTC 2009-06-04 16:32:36
Writing application : mkvmerge v2.4.1 ('Use Me') built on Dec 5 2008 18:30:05
Writing library : libebml v0.7.7 + libmatroska v0.8.1

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 1mn
Bit rate : 4 507 Kbps
Width : 1 280 pixels
Height : 544 pixels
Display aspect ratio : 2.35:1
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.270
Stream size : 3.74 GiB (86%)
Writing library : x264 core 65 r999 cc51047
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=7 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=4507 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Language : English
Default : Yes
Forced : No

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Codec ID : A_AC3
Duration : 2h 1mn
Bit rate mode : Constant
Bit rate : 640 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 556 MiB (12%)
Language : English
Default : Yes
Forced : No

Text
ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Title : Romanian
Language : Romanian
Default : Yes
Forced : No

Thanks for the help!

I would tinker around with the Pioneer Elite settings … in case something funny is going on

eg. (from a quick google search)  … probably not the problem (but it does sound “sus”)

“Zone 2 - stereo audio - multichannel inputs are downmixed”

“Zone 2 now downmixes digital inputs to stereo, whereas previously you were restricted to analogue inputs for the second zone”

http://www.avsforum.com/forum/90-receivers-amps-processors/1392589-pioneer-receivers-2012-vsx-xx22-sc-xx22-elite-vsx-6x-elite-sc-6x.html

Thanks for the reply.

I tried “Pure Direct” setting; which basically is the AV Receiver accepting the source nearly untouched and the results are the same.  Also, I don’t have this on Zone 2.

It just seems that the WD TV is trying to decode it before passing to receiver.  It will be great if the WD TV can just pass all of it untouched.

Any additional suggestions?

Thanks.

I did experience this issue before but I am nsure whether it would be the same as what you are facing.

Initially, I use to download torrents without checking for the audio format as the player plays most of the formats. Even when some of the torrents states that it’s 6 channels or DTS or AC3 but eventually I found out that when I did the actual analysis using a software, it’s was under AAC or 2 channel stereo format. That was the reason why the movie only supplied me with stereo audio and not dolby digital or DTS.

After that, I have had no problem with the audio part and I hope this helps. If I couldn’t find those with DTS or dolby, I’ll just download those with 6 channels and then convert them to AC-3 format and it works everytime

Hi

The WD TV Live does digital audio pass through hdmi and optical. Go to Settings, then Audio/Video Output and Audio Output choose digital passthrough HDMI. I hope that helps

Hi,

What program did you use to do that conversion?

Thanks.

Hi,

Yes, I have the audio set as passthrough via HDMI.  But it appears that the WDTV passes different formats and converts some before passing.  It appears to decode the Dolby Digital codec before passing.  I would like to pass it untouched.

There must be something going on. Mine can passthrough Dolby Digital 5.1 and DTS 5.1 and even stereo soundtrack to Panasonic home theatre. Have you tried to reset it to factory defaults? About your other question, audio conversion I use XMedia Recode, a free application. I mainy use it to convert MKV to m4v for use in iTunes. The good thing is you can have video passthrough if the codec is AVC and just convert the DTS to both aac stereo and Dolby Digital 5.1. It also supports soft subtitles if they are srt or advanced sub station alpha. You can even maintain the container whilst converting only the audio. It is fast if you don’t transcode the video. The website is in German, but it is easy to use and there are tutorial videos on the web should you have problems.

I am using this software called XviD4PSP 5 to convert all those video which has AAC audio format as my amplifier doesn’t seem to read it as 6 channels. This software also shows you the movie info as you posted earlier and that is how I check whether the torrent that I downloaded is actually what they described.

Hope this helps as it did me.

Cheers!!

One thing I just thought of; try to manually set your audio passthrough and make sure Dolby Digital is ticked in audio settings. Maybe the WDTV Live thinks that your receiver cannot decode the AC3 signal and is therefore transcoding it. Hope that helps.

Thanks for your input.

I tried the manual process as well with no success.

How would you convert the audio using the software you all mentioned?  The media info is saying the audio is already at 5.1 dolby digital.  Can it convert (correct) audio from 5.1 dd to 5.1 dd (basically redo the track at 5.1 dd just in case something is bad in it)?  Or will it have to be something like 5.1 dd to 5.1 dts?

Thanks.

Yes you can convert DD 5.1 to DD 5.1 using XMedia Recode. You can change the bitrate as well, or keep it the same. You also have the option to convert 5.1 to stereo  but not stereo to 5.1! You can convert DTS to either DD or aac and convert between aac and DD. Just make sure you copy the video, not convert it as it takes longer with the latter and degrades quality. Try it and see if it helps.

Well, i can recommend another one as well (nice and simple)

Avidemux

http://fixounet.free.fr/avidemux/

  1. Open your video file ( Video Output  *Copy*)

  2. Audio Output *AC3 (Aften)*  select configure and filters (see picture for settings) *

  3. Output Format If your video is MKV then select MKV Muxer

  4. File > Save … wait about 10-15 Minutes (depends on the size of your video)

* usually i dont change the audio filters… but in this case i would recommend you do it

Sorry for the late catchup here I have a pioneer elite and sometimes I get no sound so I have to turn off the reciever and turn it back on while the file is playing then I have sound. Sometime when I view a trailer it is staticky and low volume and doing the same cures it. All of my files are ISO however

The feedback has been awesome everyone!  The method by JoeySmyth appears to work; which is great news! 

There is just one thing about this process that hopefully you have some suggestions.  Is there software that can output the Audio Bitrate at 640 instead of the max 448?  It’s probably not that biggy in terms of quality difference.  I should be happy and just move on, but this is just something in the back of my mind when I think quality loss.

Thanks again.

PureUncut wrote:Is there software that can output the Audio Bitrate at 640 instead of the max 448? 

Fiqured out a way with Avidemux   (just quickly, it’s not elegant … but it works)

  1. Do everything in the picture above (open the video, select the settings) … but don’t save the video just yet !

  2. File > Project Script > Save As Project > MyProject.txt         (*.txt is super important)

  3. Open MyProject.txt in notepad or notepad++

  4. Find this code       adm.audioCodec(0, “Aften”, “bitrate=448”, “mode=0”)  and change to “bitrate=640”  

    close and save.

  1. Rename MyProject.txt to MyProject.py      (*.py is Python Script File Format)

  2. File > Project Script > Run Project     open the MyProject.py file

  3. Now, save the video as would normally … and presto, the finished file will have a bitrate of 640Kbps

1 Like

XMedia recode supports up to 640 bitrate DD. Open the programme. Set the profile to custom, format to matroska video as shown below

Click on the file, and on the video tab, choose copy as shown below

On the audio tab. click on the audio stream you want to convert, choose codec AC3, channels 5.1, and bitrate 640, then click the arrow as shown below.

Finally click add job and encode as below.

XMedia Recode add job.JPG

and your file will be ready in a few minutes.

1 Like

Hi,

The solutions provided by JoeySmyth and musimboti are excellent.  They both outputted the same file size for each solution at 640 Bitrate.

Thanks to you both and everyone else who assisted.