FTP on EX2 still broken in firmware 1.03.41, 3 months after reporting it

Back in March 2014, right after EX2’s launch, I had reported that the FTP functionality was broken because of a bug in the FTP configuration screen and worked with WD’s L2 tech support via a remote desktop connection to show the issue definitively. Weeks later, my ticket was closed out without a notice or without any fix. When I contacted WD, I was told the closing of the ticket is routine procedure, even for known issues (which seems a VERY odd process to me). Anyway, a day later I got the following email from the L2 tech who had worked with me assuring me that WD is aware of the issue and have been able to replicate it - and assured me that a fix will be included in the next release (see circled part in email pic - or if it’s not visible see the pic here -> .

Ok, since then we received two frmware releases. I understand that it wasn’t included in the Heartbleed SSL firmware fix as that was only to address the Heartbleed SSL issue - but today after I updated my EX2’s firmware to 1.03.41, as I suspected (since I saw no mention of the FTP fix in the release notes) FTP is still not working on EX2. I had another My Cloud Mirror user confirm that the same bug exists on My Cloud Mirror as well and Mirror also cannot therefore use FTP. I suspect it may also be broken on the EX4 since EX2 shares the same codebase with EX4 - but I am not sure for EX4.

I am still unable to save the external IP in the FTP config - rendering the FTP functionality unworkable since to use FTP in passive mode this external IP must be saved.

I couldn’t believe WD shipped the product  with this bug - but fine, I patiently waited once I was assured a fix will be provided in the “next firmware release”. I have no idea when we will have this fixed. It’s been over 3 months. It is really unreasonable to wait this long for a firmware fix that doesn’t even include a fix I was promised. What’s going on folks?? Seriously, I am not very pleased about this.

Here’s a screenshot of the still unresolved external IP screen in the FTP config from the dashboard.

I have to agree, the quality of the firmware may well be the downfall of this product.  Not to mention the fact that they released the exact same product in white calling it the mirror but for 20 bucks less.

Indeed. And given how the EX2’s website markets FTP server as a key part of it’s “Advanced Serving” feature…when it has been broken from the get go. This is a cropped screenshot taken from EX2’s product page (Advanced Serving tab) - alternate link here ->  http://imgur.com/iLR9WkT

FTP server webpage.jpg

I am not one of those forum users who come here only to gripe about WD. Over the past three months I have tried to help some users sincerely. And if I have the time and knowledge, I still will. But I am deeply disappointed by the lack of support from WD on an issue that even they acknowledged was broken. Especially something as crucial as FTP and something that is touted as a feature, yet doesn’t work.

Hallelujah! WD has finally fixed the FTP bug in firmware version 1.04.05. Now I can save the external IP setting in the dashboard’s FTP configs. After five months since I reported this bug. About time!

I still have to resort to the config.xml hack I had discovered back then to adjust my port and my external IP settings. WD’s dashboard config only allows ports 21, 2121 or 9921 for FTP but because my ISP blocks port 21, I could use only the other two ports. However, since I have been using port 44 as my ftp port for a while, long before I bought the EX2 NAS, and since I cannot save port 44 using the dashboard I still have to rely on my manual fix of config.xml. But at least most people can now enjoy FTP without doing anything manually via SSH. But I can finally consider this issue resolved and closed.

Cybernut1,

If you use the implicit SSL option this will default to port 990 which is not blocked by most ISP’s and has the added benefit of providing an encrypted link for sending your valuable data such as your username and password. Otherwise they are sent as plain text across the internet. 

Thanks Vertech1 - I did notice last night the new options Implicit and Explicit ftp. But I have no motivation to use FTPS. I really pushed to have this FTP fix implemented so that other users can benefit and use FTP - plus I may sell my unit to a friend who does not have the expertise to maintain my custom firmware mods.

I myself have been using SFTP since early-April ( http://community.wd.com/t5/WD-My-Cloud-EX2/SFTP-possible-on-EX2/m-p/715812 ), ever since I created the hack for it. My friend who uses  SFTP to log in uses password-less SSH-key-only logins, so I have been able to bypass the insecure FTP for the most part. I needed to use FTP for only a short time for a couple friends who needed access for a short time and I wasn’t going to create SSH keys for them.