Found some kinda SOLUTION for problems related to USB stuff

The device in question is a 4-year-old WD Element 1TB; The Problem Windows10 can’t open it; it just shows up as E:NTFS
FYI; not mine, it was my cousin’s But because he was getting this he brought it over
A few things:
-As soon as I plugged it in the front panel USB port it started spinning
-Windows played that sound when you plug in something
-I had WD My Dashboard and Discover installed (for my own Drives)
I Couldn’t get through anything; I did THE MOST RANDOM THING EVER
I had a hirensbootcd on a 4gb, first I disconnected the WDE, turned the PC off, popped that hirensbootcd inside a USB3 port, boot-up, boot inside the live session, then connected WD Element to the same port, BOOM voila, I copied everything that was on it to another drive.
Turn off, Disconnect, Boot up normally, back in Win10, I had the copies and all, again tried to connect WDE to the same USB port, SAME ERROR; so I did Re-format the device since I had the Data and now its working just fine

Hi @lestattheraven,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: