Wd elements 10tb won't power up

hi all
So I am in the process of moving to a raid format and this 10tb I bought last month was being used to consolidate data so I could create the raid, etc. Of course now the 10tb will not power on. I tried the power button, switching out the USB cable, etc. I think that the power port fell into the WD as now something rattles when I move around the elements.
Can I open this without voiding the warranty to try to fix it myself?
Any other thoughts?
There is some data on this drive that is not on the other back up drive I have.

Just to update. I did get the shell off and it appears that the port for the power broke off and did fall into the device. I cannot tell how it is supposed to be hooked up.

Last update. Since I opened the drive it voided the warranty, which I expected. I had talked with a friend who suspected the damage may not have been covered anyway. Luckily, just plugging the drive in after I took it out worked fine and it is connected to my pc. I ordered an external enclosure for it.