Found a way to connect Cloud Home Duo via Local Network But Still Got Problems

Hello everyone,

It’s been 3 weeks or so since I lost connection to my wd home duo 16tb.
I have setted it up with ease when I first got it before a month ago. Choose the option to use mirror backup 8tb/8tb raid option. Then after a few days I lost my connection to the white box :slight_smile:

I was trying to acces my files somehow with no luck.

WD shared a knowledge article to show how to enable local access on windows/mac devices.
I tried but still it’s not working like they say in this article: Instructions to Enable Local Network Access on a My Cloud Home, My Cloud Home Duo and SanDisk ibi

When I try to type in http://MYCLOUD-123456 (last 6 digits of my serial no) in my browser;
it opens up an error page with “{“key”:“notFound”,“message”:“Not Found”}”

So I can’t proceed to further steps and gain local access. I can share a video if someone wants to see.

Anyway, when I try to discover MCHD on my pc network, Its not discoverable aswell.

But when I open explorer page with windowskey+E and right click on the “My Computer” in the list at left panel, and choose Map A network drive, I manage to map my MCHD with \MYCLOUD-123456\Public\ address.

Another way to do it: open any folder on windows, and type in \MYCLOUD-123456\Public

It asks for username and password. I just typed in admin - admin

Hope this helps to someone since I cant get any help from WD support.

BTW I need help to connect WD MCHD Dashboard locally. Please inform me if you know a way to do.

1 Like

The second way to access your MyCloud device from Windows is the correct one as explained in the WD Instructions.

However, you should not use the admin-admin combination to access the device. Before you do that, you should enable local access creating a completely new account and password, as explained in the fourth youtube video you see at the top of the instructions page.

You have to do that because remote access to My Cloud Home devices have been disabled since April 2, due to a hacker attack that WD is still trying to get out of.

You must type

End must be /

When I type in http://MYCLOUD-123456/ (using my serial number ofcourse)
It opens up a blank white webpage with a single line:
{“key”:“notFound”,“message”:“Not Found”}

I still not able to connect to the loacl access, it said cannot find the network in the web browser , “DNS_PROBE_FINISHED_NXDOMAIN”…

feel very disappointed and hope the online access will be fix asap…>.<


i think i got the same problem as you…

anyone can help??

Have you done this first?

Yeap, problem is when I type in http://MYCLOUD-123456/ it opens up a blank page with an error message.

error is: {“key”:“notFound”,“message”:“Not Found”}

so I can not proceed further


http://MYCLOUD-123456/ is the EXAMPLE placed in the article. The last six alphanumeric characters of your Serial Number could be ABC123 or XYZ789. You’ll need to check the label for accuracy.

I know, I dont share mine for security reasons…

Just got a Home Duo and having exactly the same problem. I watched the videos and the issue seems to be that you can’t access the dashboard until you enable local access, and you can’t enable local access until you can access the dashboard.

The two videos are circular in that way. Is there any way to circumvent this ridiculous problem?

It is doubtful you have anything in common with the WD self imposed server outage in early April, 04/02/23 to 04/12/23 which is the subject of this thread, although nobody bothered to identify the announcement here:

Service Outage

02 Apr 2023 Outage

Western Digital is currently experiencing a service outage impacting the following products: My Cloud, My Cloud Home, My Cloud Home Duo, My Cloud OS5, SanDisk ibi, SanDisk Ixpand Wireless Charger.

You can check the currnet OS4 server status by going to the same site linked above or just click here.

You have just have to log into the webapp (browser at in order to get to the dashboard through the settings menu of the webapp. If you can’t log in with your WD ID, try a different browser that tracks your identity, for example Chrome and Edge are pretty good at making money by tracking your ID.

There is no problem if you have the right identity and the OS4 authentication servers are active. If either side is broken, then there is a problem.

If you didn’t bother to turn on the UPnP functionality on your router or if your router is incompatible, the My Cloud Home will also have a difficult time accessing the WD servers and will be unable to identify that the MCH is “Local” to your subnet and you will not be able to enable the ‘enable local access’ feature.

The subject of this thread is a problem where the user can’t access their own local server on their own local network without a remote connection to a third party. I have exactly the same problem that the top poster had, even if our circumstances are different.

I am dumbfounded that there would even be a setting for enabling local access, I can’t think of any scenario where that should be disabled. Even if there is such a scenario, the fact that it is disabled by default is absurd.

But I’m just ranting now, I’m clearly not going to get a satisfactory answer here. I should probably just return this useless thing.

This was answered by A Cintoli on Apr 9, 2023 during the outage, even though he didn’t link the OS4 status page which is what I supplied in the previous reply.

You don’t understand because you don’t understand security and you don’t know what the My Cloud Home is all about.

No owner or user of the My Cloud Home (or Duo) has root access. This allowed a higher level of security and privacy than either the OS3 which got hacked or the OS5 which is more secure but still vulnerable because root access is available.

There is a setting for enabling local access because it is the first time that the My Cloud Home has had any local control over the functionality of the MCH through the introduction of the Dashboard which necessitated an authentication process to determine who has access to local control. Prior to its recent introduction, there was no Dashboard for the MCH and all control was through the the webapp or mobile app which required web authentication in order to gain access.

You should return it because you don’t know what you have bought.

If this was really about protecting privacy, using my device on my home network wouldn’t require me to agree to a privacy policy which includes such gems as: collecting location information, financial information, and sensitive personal information. And then sharing that with other companies for the purposes of marketing, advertising, sponsoring of sweepstakes, contests, and other promotions, data analytics, etc.

There seems to be no limit to what information Western Digital can collect, and what they can do with it. All of which I’d have to agree to in order to use my device on my home network.

I suppose that I can be sympathetic with the difficulty of making a device which is remotely accessible and yet still secure when put into the hands of novice users. But protecting my privacy is the reason why I don’t give internet access to random devices on my network. Is it possible for an object to be an oxymoron? A “trustworthy closed-source user-inaccessible unauditable device.” Nonsense.

If you are referring to the WD Privacy policy statement, then you have misunderstood.

  1. The original reply I gave was that the My Cloud Home guest users have a lot more privacy against snooping from the administrator (the owner) of the MCH. That level of privacy cannot be achieved by the OS3 and OS5 or even Synology users.
  2. Western Digital is not Google or Microsoft, Amazon or Apple. WD doesn’t have my telephone number, address or anything else other than an email and IP address. This is true for any WD users who DID NOT have an account with the WD webstore and did not give WD their personal data other than an email which is the only requirement for activating the My Cloud Home.