Formatting failed


#1

Help please!

Bought two 4TB My Passport which has the remark (+reformatting required for Mac OS). when tried to format , error message pops up “Erase process has failed. Click Done to continue”

Both Hard drives shows the same message.


#2

Same here with 2TB Elements. All functions in Disc utility - such as run first aid for the disc or partition are similarly unresponsive. I think I have a broken Elements ext HD? have submitted a support request and awaiting a reply which could take 2 working days - not very happy.


#3

The good news - support replied with the answer in my case. Elements HD now working. Here’s what I received from support:

1.Go to Applications > Utilities > Disk Utility

2.Locate your drive under External drives (it should show something like disk1s1)

3.There is a button on the top left of the Disk Utility window for view. Change it to Show All.

4.There will be two lines corresponding to the drive.

5.Restart the erase/format procedure. But this time, instead of selecting the volume (the second tab), please select the first tab (the drive). The issue should be fixed.


#4

Michelle44
Thank you so much for the clear way that you explained how to reformat the WD disc. I was being driven bonkers trying but it was the simple ‘change to show all’ that did the trick.

Harry4


#5

Thank you followed the instructions given and it worked.

Luce