My Passport Won't Format

Hello all,
Today I bought the 4tb “My Passport” from Best Buy. I came home to set it up and backup my computer (a 2015 MacBook Pro running El Capitan 10.11.6) Before I did anything to it, I read through the user’s guide and saw that I needed to format it to use with my MacBook. So, I followed the steps- I went into Disk Utility, selected “My Passport,” clicked “erase,” selected “OS X Extended (Journaled)” as the format, and clicked “erase” once again. After working for a moment, it told me that the operation had failed because “MediaKit reports not enough space on drive”


But after that, I could no longer even access My Passport (Notice in screenshot how it is now dimmed and called “Untitled”) So, I unplugged the drive, waited a minute, and plugged it back in. When I plugged it back in, I got another error message saying the drive was not readable.
Confused, I went back into disk utility, and tried to format the “Untitled” drive, this time as MS-DOS, and it failed again, with the same error message about whatever “MediaKit.” Defeated, I clicked “Done” and left the drive plugged in. A few minutes later the drive reappeared as “My Passport” as if nothing had happened.
I may just be making a blatant mistake somewhere along the line, but I’d appreciate if someone could help me out.
Thanks!

Try selecting the WD at the hard drive level i.e. “WD My Passport” this time (not Untitled) and then Erase.

Thanks! It worked! You were right, you did indeed have to select “WD My Passport…”


After I successfully reformatted the drive, I went and rechecked the instructions:

Step 2 is what got me. It did say the one farthest to the left, and it named the drive “WD My Passport ____ Media” which, in the end, was the correct one to erase. The pictures stated otherwise. It was a confusing mess in my head, and I suppose I should have tried that before coming here.
Thanks for the help!

I FIND ALL THIS LAUGHABLE. I signed in here just to vent about exactly this. Every time I buy a hard drive it’s a gong show. So, my seagate falls off my table tonight- toast. I buy this my passport -seems tougher. Of course -Cant get it to format. I am tempted to just click the ‘my passport’ instead of the subheading but oh no, i spend an hour in safe mode following this:
https://support.wdc.com/knowledgebase/answer.aspx?ID=8575
I found it extremely amusing that when I open this forum the first topic at the top is exactly this…
WHY WHY does it have to be this way - mis honkin leading instructions every time…I will improve the conversation by saying thx to Donald for helping Dean and Dean, you aren’t the only one…
ps I knew i was in trouble right off the bat when I googled the WD website and within a paragraph there the red ink telling me about the possible error and trouble…

2 Likes

Highly laughable from not having the drives pre-formatted for Apple to horrible instructions on how to do it. If I didn’t find this thread, I was close to throwing both drives I bought right into the garbage. Should have stayed with Lacie.

1 Like

I have a My Passport Ultra. I believe the drive is bad because I can’t erase it. I am using a Macbook running El Capitan. The external drive doesn’t mount either. When I try to erase it, I am getting “Unable to write to the last block of the device”. When I try to run WD Utilities, I can’t complete the drive tests and it fails on the drive status check. My conclusion is the drive is bad. I wonder if the cable is bad. Unlikely the cable is bad but who knows.

A joke. It shouldn’t be such a pain to format a drive for a Mac.
It wasn’t always this way. The second one I’m returning to Amazon
and ill use another companies.

1 Like

Well maybe this is of help, cause it solves the Problem. At least to me

the solution is to user the diskutier from the command line

-> Start the terminal.app

enter the following to Format the corresponding disc(e.g. /dev/disk6) in “Mac OS Journaled” (e.g. JHFS+) and give the volume the name “Emptied”
diskutil eraseDisk JHFS+ Emptied /dev/disk6

Explanatory, what each parameter means

diskutil eraseDisk FILE_SYSTEM DISK_NAME DISK_IDENTIFIER

1 Like

That’s exactly what I was thinking right after I plugged this in. And then I happened to have the same problem mentioned above. AGH!

I have the same problem. i would do as suggested but the root directory is no appearing. i have only the my passport folder. only the folder that has the arrow sign on it indicating mounting and unmounting

i have tried every possible way. using different computers with no success. finally i opened the WD software that came with the HD after installing it in my mac. an application utility enables me to erase the HD in the format readable by mac

1 Like

Same. the suggestions at the top of this thread didn’t work for me. I had to install WD Utilities and then erase/reformat the drive in that application. I think the Mac OS doesn’t know what to do with it in the windows format

I am trying to erase under exfat format and master boot record since I want to work with both windows and iOS but message says “the disk is too large to be supported by the given partition scheme. Operation failed”
I have a 4 TB WD passport hard disk. Can anyone help?

try with terminal http://osxdaily.com/2016/08/30/erase-disk-command-line-mac/

Thank you. Will try it today and let know…

I am totally pissed. I purchase this wd passport 2 tb and I feel like smashing it against a wall. I simply wanted a normal external hd that I could attach to my computer and use it. But no. Couldn’t do anything. I don’t need all this ■■■■ security or backup. I tried reformating it but wouldn’t let me. Couldn’t eject it, had to unplug the usb but it was still on my computer and it refused to eject. Locked my computer and had to restart. Wouldn’t even mount anymore. Piece of ■■■■. Returning tomorrow. How do people give this thing such good reviews beats me.

What WD model? What macOS. And what file system you were trying to format it to?

Similar problem. Bought WD 6T external My Book to use with Time Machine.
Tried to format in Disk Utility by erasing - Mac OS Extended (Journaled) & GUID Partition Map.
I get the message “Erase process has failed”. Details say Unmounting disk, couldn’t unmount disk, operation failed.
What did I do wrong? Any help is greatly appreciated.

SIerra 10.12.6
iMac Late 2015 21"

the best way is to use WD Utilities to format the drive under Mac OSx. Some Mac OSX version does not know how to handle a drive that preformated as GPT/NTFS.

Thanks immensely! That did the trick.