Error message when formatting a new drive

#1

I’m following instructions but keep getting the following message “Erase process has failed. Press Done to continue”. Before I return the drive, I’m hoping someone here might have come across this and knows what’s gone wrong.

#2

I assume you’re trying to format it on a MAC, probably the error is because it failed to unmount the disk.

Try to eject the drive (If you can see it on the desktop or finder) or restart your computer then try again to reformat it

#3

Thank you for your prompt response. Yes, I’m trying to format it on a Mac (sorry, I thought I had posted in the Mac section). The drive does not appear on the desktop or the Finder. I did restart the computer as you suggested, but again received the message “The disk you inserted is not readable by this computer”. Attempting to Initialize it gets the same message as before.

#4

Turn off your computer, unplug the drive, plug it back when the computer is back up and try to reformat it again. Let me know if that works.

#5

Again, thanks for your continuing efforts to help.
After doing as you suggest, the message that appears is “The disk you inserted was not readable etc.”
I already have two WD drives which I have correctly formatted, and they are working as they should, so I’m beginning to suspect that I need to return this drive to the vendor.
Angela

#6

Did you delete the partition before formatting the drive? If not, you may be attempting to format on top of a Windows partition.

#7

Erasing the disk is exactly what I’m trying to do (in Disk Utility). I keep getting the message “Erase process has failed”.
Thanks for attempting to help.
Angela

#8

Look at this article to make sure we’re not missing something. Otherwise you may have a failed drive in some way. I would also try another cable while you’re doing it.

#9

I was actually following the instructions in that same article and getting nowhere. I have a number of cables, but none that match the one that came with the drive.
Thanks for your attempts to help but at this point, I think it’s time to give up and return the drive.
I don’t understand why that information (the article) was not in the box.
Angela

#10

This happened to me, too. The screenshot shows that you should delete one level lower in the hierarchy than actually works. Instead of selecting “My Passport”, selecting its parent “WD My Passport” and following the remaining instructions worked.

Hope this helps someone.

Sometimes in life it isn’t just RTFM, it’s FTFM (the F is for Fix).

#11

Hi!!! I hope, you have got your WD becasue I found the true solution!! Please try it!

  1. Find another computer, that’s not a MACBOOK or Imac or anything what works with OSX system.
  2. DO NOT USE an OSX SYSTEM! :smiley: :smiley: :smiley: Try to find a WINDOWS system…
  3. plug in the WD to the Computer (that has the Windows system). Format your WD and on the normal PC. Plug out safely when it’s done.
  4. Plug in the WD to Mac, and try to format… Sometimes it wil give you the same result, somehow it does something (I don’t know what) and there will be the Official name of the HDD and after that erase it, and it will work!! :slight_smile:
  5. Believe me, I tried. And now it works. I was arguing and I was upset, because it didn’t work, but when I found this amazing solution I was happy. And I am still happy! :slight_smile:
#12

Hi, someone could already solve this problem?. I bought two WD Elements discs and the same thing happened to me.
I already tried to format it in an PC with Windows, but it does not see it.

#13

i was just having the same issue…
when your in disc utilities click the view tab than select show all devices than give it a try

2 Likes
#14

I have a reliable fix for this but it still requires a PC.

  1. plug the drive into pc and just delete the partition so you have the whole drive an unallocated space.
  2. plug it back into the mac, now you can format the drive to HFS+(mac journaled)

I’ve done this with a few drives now and had success each time.

#15

This worked for me!! Thank you! I was about to return this ■■■■ thing lol

#16

easy SOLUTION Using MAC only

Open Disk Utility
Select WD Drive
Click “View” upper left, and click down arrow
Select Main Drive (not volume, that’s what’s causing the problem)
Now click “Erase”, enter name, select OS Extended (Journaled), and Scheme is “GUID Partition Map”
Now Click “Erase” button.
You should see it succeed now.

1 Like
#18

Thank you so much this WORKED!!!

#19

Thank you. That was exactly it. Problem solved. You need to select the disk name one level higher.