Flashing red light on first boot

Hi everyone,
I just bought a 2 TB My Passport Wireless. First thing, I changed the disk extension to NTFS and I copied a couple of movies on it.
When I try the first boot of the MPW as showed on the user’s manual, both LEDs start flashing red. I can’t do the reset by holding both buttons in for 10 seconds because the MPW’s lights start blinking almost immediately.
Any advice? Should I call the seller to change my MPW?


Marco, see this long post of mine that gives you steps to clear this issue up. Basically, the first parts of the thread is what you need to know.

Hi Mike,
I already read that topic. Unfortunately my MPW doesn’t even start. When I try to boot it, the battery led blinks white. After 3-4 minutes both leds start to blink red. So I can’t try to restore it.
Any thoughts?

Did you see this:

What were you doing when it went haywire? Were you installing firmware, and if so, did you give it plenty of time to finish the job?

Your MPW, IS starting, and giving you flashing red LEDs, so to stop this, you need to start the restore process. So, read my instruction to do this from the start, it tells you that you need to do Part 1, so you need to basically start the restore when unit is ON, hold the two buttons in for the 10 seconds or so time required, and then allow device to go to work flashing LEDs of different colors for 3 or 4 minutes until it settles down and the flashing red LEDs are stopped and you have the correct LEDs lit. Then turn it off. wait a minute and turn it on again and check it and maybe need to do the restore one more time, and WAIT for it all to get restored again.

If it does not restore you have a major issue, so try to exchange it with seller for a replacement NEW one. If they give you a hard time, then contact WD Support. You will have a working MPW sooner or later, let’s just hope it is “sooner”. OK? Go for the restore. Charge the unit first, (with MPW off) it has likely lost some. Give it at least an hour charge if the LEDs aren’t working right, and charge it enough before turning it back on.

Thanks for your reply.
I just turned my MPW on. LEDs started blinking red after a couple of minutes. I tried to restore it holding the two buttons but the LEDs keep blinking red. I guess this is the major issue you were talking about, right?

Could be, so did you release the buttons after about 10 seconds when the drive appeared to be entering the restore mode but it didn’t, then yes, it is likely toasted. So you tried, now work on getting that exchange you deserve.

I waited more than 10 seconds and the MPW keeps blinking red.
Thanks anyway for the support. I hope I won’t have issues with the exchange or with next MPW.

OK, I hope you won’t have any issues either. Report back once you get some progress made on the exchange, etc.