Flashing blue light - My Cloud not available



@cat0w The Link LED is green Solid and the Activity LED is Green - Blinking

@Migwel This tells me it is connected to your router and working. What have you set up in the Dashboard? What device are you trying to use the My Cloud with that shows it as unavailable. Have you rebooted your router and the device you are trying to connect with? How long have you owned your WD My Cloud?

@cat0w I know that’s what it looks like but it’s not. I’m checking the list of connected devices to my router and it’s not showing up there. I tried restarting the My Cloud as well as the router and my laptop, to no avail.

I’m trying to reach it through the usual channels (Android app, Windows directory, files.mycloud.com, Linux NFS), none of which works. I own my device since February 2019.

@Migwel What Router or Modem Router do you have? Does the router have more than one Ethernet connection, if yes, have you tried a different one to see what happens? What are the LEDs on the Router Ethernet connection doing if anything?

@cat0w It’s a ZTE H368N. Yes, it has multiple Ethernet connections (to be correct, I’m using an Ethernet Switch). I’ve tried to use a different one (which I know works because I tried plug in another device into it) as well as using a different Ethernet cable (same here) but it didn’t help. There are LEDs on the Ethernet switch and when I plug in the My Cloud’s Ethernet Cable, the LED turn green on the switch.

To be clear, i’ve had this setup since the beginning and didn’t change anything recently.

I am having same problem
I had an existing MYCloud until a few weeks ago which I been using with no problems until it got dropped (possible hard drive error my Techy says) so I bought a second hand one which was wiped clean before I bought it so it did a factory restore and a firmware update when I was installing it and the blue light is absent so I don’t know what to do or where to go

@ardentbuzz I don’t think you’re issue is related to mine. i didn’t drop mine and the blue light is not absent, it flashes.


Bad news, I’m afraid - Your system software is corrupt. See this post. Disgraceful state of affairs on WDs part, but there have been too many instances of this:

Hey @sktn77a
Unfortunately, I tried to follow this procedure already but when I plug the USB in and reboot, nothing happens and the light is still flashing blue. I did reformat my USB stick into fat32 and extract the boot folder into it but with no luck.

Also, any idea why this happened now specifically? I didn’t update my system. I probably enabled automatic updates but I would then expect not to be the only one to be impacted

“I probably enabled automatic updates but I would then expect not to be the only one to be impacted”.

I think that’s probably the case. My daughter’s 4TB MyCloud v2 just did the same thing and there are other example on the web. Not everyone with the problem bothers to google it or come to this website. I’m sure there are hundreds (thousands) of MyClouds gone the same way.

Hmmm… Did you extract the zipped usbrecovery.tar.gz file to the USB drive? How big is the USB drive (use the smallest one you have). The only thing you should have on the USB drive is a folder called “Boot” with four system files inside it (they must be in the boot folder, not just in the root directory without the boot folder)…

This is just awesome. Sounds like a firmware update bricked our WD2100s? You would think a company like Western Digital would do a little more QA before releasing something like this.

Has anyone successfully recovered their system, and if so, what version of firmware did they use?


Well, I’m only aware of this issue with the single drive MyCloud. Haven’t seen any issues with any of their other NAS boxes (but that doesn’t mean it hasn’t happened).

Yeah, this is a DL2100. Seems to be stuck in a reboot loop. I am so pissed - this is the second time I have had a problem with this unit. The first time it rendered my data useless. I am still recovering it with EASEUS.

Now, I come home from vacation, and it’s DOA. I bought a WD RAID box because of the brand - I did not expect this many problems from it.


I’m having the same problems with my 2Tb My Cloud. Blue flashing light. Been working fine up until a couple of weeks ago. Same PC. Same router. Have tried the 4 sec and 40 sec resets. No different. Have also tried to the reboot from USB following all the instructions religiously. Still got the blue flashing light. The device contained the majority of my music library and I have since disposed of the original CDs. I know this was stupid without creating a secondary backup. I’m not too bothered if I cannot get the device operational again as long as I have some means of recovering the data. Any more ideas?

As long as the internal HD in the device isn’t damaged, the data is easily recoved.

  • Disassemble the MyCloud
  • Remove HDD from enclosure
  • Attach HDD to a different computer RUNNING LINUX
    • this can be a linux live cd/usb - which means you don’t need to install it
    • any flavor of linux will do - ubuntu, debian, fedora all have live usb
  • Attachment can be via an appropriate USB docking station or cable

The data partition is the largest one, and it is partition 4 (on Gen 1 devices, maybe the same on Gen 2). It is formatted as EXT4 (a linux-native file system), thus the need for a host linux machine to read it.

After that it’s a matter of copying your files off of the MyCloud HDD and onto some other media, like the internal HDD of the host linux machine, or an external USB drive, or over a network to another machine on your LAN, onto a different MyCloud on your LAN, or anything else you can think of.

I resolved my “reboot loop” problem yesterday (details in this post). If yours is doing the same thing, mabye the same solution will work for you

Many thanks for that reassurance. It may not be a few days but I will give that a try and let folk know how I get on.

While it is generally best to use Linux if recovering the data or to unbrick the drive, it should be noted that one can use Windows 10 to recover the data off a Linux formatted hard drive using software like Linux File Systems for Windows by Paragon Software.


Little bit more discussion on using Windows 10 to view/access the contents of shucked My Cloud Hard drive:

My Cloud dead, how to see content on Windows 10?