Failed Upgrade to OS 5.14.105

Hi

I have a DL4100 which is currently running 2.41.116 and I was notified of an update to OS 5.14.105 however every time I try the update it fails and the only error message I can see is “Update Failure”. I have tried looking through the logs but I can see anything.

Several times I have tried clicking on the link under Available Updates. The file is downloaded but as soon as it starts to the update it fails. After each attempt i do reboot the Dl4100

I have also tried the manual update route but with the same result.

I have read the instructions and I am seem to be follwoing the process.

Has anybody any suggestions on how to sort this out?

Kind regards

Steve

Hmmm. . .that’s a rather disheartening thread.

So lessons

  • NEVER encrypt NAS volumes. . . . . it will just make it that much harder to do a doomsday disaster recovery

  • ALWAYS backup a NAS. . . .RAID provides redundancy for HDD’s. . . but not for the the *$&#^ing hardware running the RAID. There is ALWAYS common mode failure potential. (Hardware, Power Source, Fire). It’s just a question of probability. (Case study: Fukushima Daiichi nuclear disaster - Wikipedia

  • Cloud storage is nice. . . .until the company running the cloud changes business model. . .or folds

As for recommendations;

  • Reading that entire discussion. . . .I would concur with the “time to start NAS shopping” recommendation

  • Buy an external HDD or two . . .and backup the NAS

  • Look . . .OS/3 is old. . . firmware no longer supported. . . fair amount of security holes. . . .“time to start NAS shopping”. . . .OR. . . .do what I do = = => Run it on a dedicated network that does not have WAN access.

  • I would not consider running OS/5 on a NAS box . .

    • WD security reputation (for fixing things) is weak
    • OS/5 is very . . . noisy. . . .for a NAS. . . .the current direction WD is taking results in doing a number of questionable things (in terms of privacy and security) in the name of “features”
    • OS/5 feature set is quite restricted relative to OS/3. . . .and OS/3 wasn’t the bee’s knees
    • The “indexing” process is. . . .bad. Just bad. Especially if “indexing” involves “transcoding” (can’t remember if it does transcoding on DL* series machines)

Is the DL line the one with with Intel atom cpu problem ?

I think qnap and synology old unit had that problem ?

and may not be your problem but
I never jump firmware updates if there is a progression to the newest build.

I do have a few failed WD NAS/cloud units fail over the last 8 years but the USB backups made reloading in a new unit only a 1 day rebuild.

I used mdadm Linux utility on one system that was able to read (and use) the WD mirrored raid disks

I also took some advice form one of the above posters and got a DS920+ NAS on Amazon prime day

Please collect the system logs, send to support and let me know your case number

Thank you very much for the response.
I do seem to be having an issue with requesting a support ticket, as the PC interface won’t upload the system logs.

I have submitted a question through the My Support Portal [210713-004123] but I can’t seem to find a way of uploading the System Report/Logs

Kind regards

I can solve it by installing first version 5.09.115 and then installing the latest version.