External G-Drive won't mount under Big Sur

Happy 2021 folks. And, sorry for the long-ish post. I want to provide as much info as possible.

I have two external backup drives for my Mac. They are 4TB each. They’re connected to my machine via USB. I performed a Time Machine backup on both of these drives last Friday or Saturday, and they were both working until Saturday night. Now, only one of these two drives will mount.

I’ve tried a Terminal operation involving the ‘diskutil’ command, but that did no good. I tried restarting , but that did no good. I tried removing cables and reinserting them. Same result.

The drive comes in two partitions (one of these is a small, 4GB partition containing utilities for the drive, etc.). This smaller partition mounts, but the main drive does not – even though Disk utility can still provide info about it. It is grayed out and it says the volume is not mounted, yet it “sees” the drive.

My second drive – so far – is working. I pray this does not stop, since everything I have is on these discs.

My system is as follows:

  • iMac (21.5-inch, 2017)
  • 2.3 GHz Dual-Core Intel Core i5
  • 8 GB 2133 MHz DDR4

And, just ‘upgraded’ to Big Sur a day or two prior to this.

Any help would be appreciated. I could probably reformat this thing and copy everything over from the other drive, but I’d really like to know what caused this before I do that.

UPDATE…

I cannot even get Disk Utility to reformat, restore, or erase the volume… I keep getting a “failed” message.

Oh, and no one from WD is responding. I have a case # dating back to the 5th of this month, and so far no one’s responded. If this drive is caput, I need to get a new one.