G-DRIVE mobile works with MacOS 10.11.6 but does not work with 10.12.6


#1

Hi,

I’ve been trying to connect my 2TB G-DRIVE mobile to my Macbook Pro running 10.12.6 Sierra. It seems to work fine on my iMac running 10.11.6 El Capitan. When connected to my Macbook, I can see it in Disk Utility but it will not mount. I’ve tried connecting via USB and USB-c.

Can you help me solve this?

Thanks,
Steve


#2

There shouldn’t be anything holding it back except for maybe a lack of power. Make sure your laptop is plugged in to power and not on battery. The only other reason would be that your newer system doesn’t like the partition quality on the drive and thus won’t mount it.

You would have to erase the drive to clean that and force it to mount. So the process would be to hook it up to your older system and extract the data. Then hook it up to your MBP and erase it in the Disk Utility and it should mount and be usable. Then put the stuff back on it.


#3

Hi,

I had already recovered the data while the drive was connected to the MBP via Stellar. Note that the drive would show up in the Disk Utility Tool but never mount on the MBP. After recovering the data and storing it on my MBP, I tried to erase and partition the G-drive on the MBP. The erase would work, First aid looked good but the partition operation would fail.

Running operation 1 of 1…
Unmounting disk
POSIX reports: The operation couldn’t be completed. Invalid argument.
Operation failed…

I then tried connecting it to my iMac. The drive was recognized in the Disk Utility but would not mount. I then erased and partitioned and then it would mount the iMac. I transferred a file to it to see if it was useable and it worked fine.

I moved G-drive back to the MBP and it still would be recognized in Disk Utility but does not mount.

I started this thread looking for help. I did what you suggested with MBP plugged in but again, it appears to erase but when I tried to partition, I get the error message mentioned above.

Also, it shows the drive with 2TB capacity but 0 kB available space. That is, it shows the disk filled.

I then tried doing the format via the CLI and it still doesn’t mount.

C02VM0R4J925:~ schubers$ diskutil eraseDisk JHFS+ G-Drive disk2
Started erase on disk2
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk2s2 as Mac OS Extended (Journaled) with name G-Drive
Initialized /dev/rdisk2s2 as a 2 TB case-insensitive HFS Plus volume with a 155648k journal
Mounting disk
Could not mount disk2s2 after erase
Finished erase on disk2

Any other ideas?

Thanks for your help!
Steve