External drive unaccessible after sleep

I own two external Western Digital MyBook USB hard drives, which I have used with my old iMac (died recently (sigh) ) without any problem. The hard drives have been connected on separate iMac ports using USB2.0 and I have turned on WD Security.

Now I have a new Mac mini and I have migrated (with the Assistant) my old settings and everything from my old internal drive to the new Mac mini internal drive. Since the Western Digital hard drives support USB3.0, I have connected both drives to the USB3.0 ports.

Everything works fine until the mac goes into sleep mode and the drives spin down. After waking it up, the drives start to spin up but I am not longer able to view/access the content of the external drives. It seems that Finder does not wait long enough and does not reattempt to access the drives.

What I have tried:
System Control->Energy Settings: Do not deactivate hard disks
WD Utility: Deactivate Sleep Timer

Maybe MacOS has migrated old drive configurations from the old internal disk which causes the problem but I don’t know how delete those configurations.

Any suggestions

1 Like

Hard drive sleep behavior settings are independent from the system (Do not go to sleep as long as the system remains active). Once the computer goes to sleep it is up to the system to awaken your hard drives. However, if the current system is unable to supply enough power to resume activity, then your units will need to be manually reconnected. There are no software settings or configuration settings able to prevent this beyond your computer’s hardware configuration.

Actually the drive is waking up but still the computer cannot access the external drive.

In the mean time I could solve the problem- It has been related to WD Security. I have a recognized in the log an entry that the driver could not access a key which had been necessary to re-authenticate.

Now I can activate WD-Security on my new mac without any issues.

is it this your problem? After sleep mode in my Mac I can not access to the disk.
Check this video: Wd My Book

Having the same exact problem with two brand new 2 TB WD My Passport for Mac drives that I purchased in January. Those drives replaced two Seagate 1 TB USB 3.0 drives that worked fine (I was only upgrading to get more backup space.) The video David212 posted above shows exactly the symptoms I am experiencing. I have disabled both “Put hard disks to sleep when possible” (in System Preferences–>Energy Saver) and “Sleep Timer” (in WD Drive Utilities), as instructed by WD tech support, but that did not fix the problem.

1 Like

Update: WD sent me a My Passport Ultra as an RMA on one of the failing My Passport for Mac drives. Unfortunately the new drive fails even more spectacularly-- not only doesn’t it wake up when the computer wakes up, but the partition map was corrupted when that occurred. At this point, my only real choice is to throw these two drives away and purchase drives from another manufacturer. If I can’t trust that my backup drive isn’t going to eat its face when the computer wakes up from sleep, then that drive is useless.

1 Like

I went back and forth with WD tech support for months. I tried everything they suggested, and nothing worked. They were quite difficult to work with, since the case would often be assigned to a new tech support representative every time I replied, and even when it wasn’t, they kept responding as if no one had read the conversation thus far. I had to keep repeating myself and answering the same questions over and over again. I finally stumbled upon this thread and was inspired to try uninstalling all WD software (including WD Utilities) from my Mac. It appears that that solved the problem. That’s a shame, because I also use a My Book Thunderbolt Velociraptor Duo, and WD Utilities is the only way to check the RAID status on the Duo.

Interesting solution to the problem, which I wouldn’t have dared to do, expose now I am thinking about it, Question: Will the Passport Ultra for Mac still work properly if all the WD software is uninstalled? How? Bottom line: I have been unable to overcome the problem of the WD backup not working if I put the Mac to sleep, then wake it up; the backup will not work. Then, in WD utilities, I tried turning off the sleep time for the backup, but it still didn’t start up properly when I woke up the Mac. I also tried uninstalling WD Discovery, Utilities, and Security and did a trial backup run–took over an hour to backup about 900 mb. So I reinstalled all that, but removed my security password so that it wouldn’t hang out up. Still isn’t working, and getting “Backup Failed” when I try to backup after letting my Mac and the Passport sleep for around 40 minutes. Have no idea what else to do to try and fix this–your total deletion of the software seems a bit extreme, but if it works, I’ll try it. Next step after that would be to give up on this Passport Ultra, and go to a different manufacturer. Would hate to do that if I can avoid it.

1 Like

Yes, the drive works fine without the WD software. It’s just a USB drive like any other, and the drivers are part of macOS. I use Time Machine rather than the WD backup software, so I have no idea if the WD backup software requires WD Utilities to be installed, but let’s just say that any non-WD software (including macOS) will work fine without the WD software. My drives have been working 100% ever since uninstalling the WD software. WD asked me to re-install it and capture a bunch of debugging information when it failed, but I have no time for that, and my philosophy is that (a) a problem this serious should be reproducible by their engineers, and (b) a problem this serious should have never made it into the product to begin with. The fact that they were expecting me to be an unpaid QA resource for them was reason enough to not trust their software again.

1 Like

Signed up to +1 DRC’s suggestion to remove WD apps. Sure enough, my little 3TB My Passport drive which would not spin up after long sleep (Mojave on iMac) now works properly.
Beforehand, it’d work if sleep was less than 20 minutes but anything longer, I’d get a window (clicking on the drive) but contents would not appear. Ejecting the drive would fail with a “Drive could not be ejected as there is an app using it” (paraphrased).
Hopefully WD can do some troubleshooting as the apps can be useful.
Thanks ever so much DRC.

1 Like

DRC! You have saved my sanity and possibly my WD My Book drives from becoming boat anchors. After installation of a new 8TB my book hard drive my troubles began with all my WD drives and revealed themselves exactly like everyone else in this thread. I don’t know why the WD chat help line didn’t have this answer, it would have made my life so much easier. I tossed
all WD apps and everything began working again. Almost hate to make this proclamation so soon, but will knock on wood. Seems to be a Mac issue only with the WD apps. Thanks again.

Thank you, DRC.
I thought it was my Mac, hardware-issue or the fact I am running a newer macOS than it normally can.
But no. It is just crappy WD-software. Uninstalled that junk and my harddrives work absolutely as the should.
I cannot understand why WD is not testing is own software. They are crippling their reputation with this.

Anyway. Thanks a lot DRC to make my server running fine without any reboots.

yes I agree this company is horrible at making a good product. It is cheap but not effective.

Has anyone found a concrete solution yet?
I deleted evert bit of WD software (including daemons),yet my WD MY PASSPORT ULTRA is inaccessible after sleep.It’s still not helping,any tips?