Drives not waking after sleep

I have a 6 TB My Book and a 1 TB passport for Mac.

I am having trouble waking drives after computer was asleep. What is frustrating is that it did not use to do this. this seems like a new thing.
I have had the My Book for a little over a year now and just several months ago, it started doing that. I have had the Passport for about 6 months and just recently started doing the same thing. It is becoming extremely annoying to have to close all the applications that are using the drives and force ejecting, then replug them back in. Any ideas what could be causing this?



Take a look at this article:

Have you recently updated the OS?

Additionally, you may want to open System Preferences and check out your Energy Saver settings which you can adjust accordingly. Within the Energy Saver menu you can find options about putting hard disks to sleep when possible (I will admit that I do not know whether that setting is for internal HDDs only or for externals as well, but it’s worth looking into). Lastly, if you cannot get it sorted, you can check into the software called Amphetamine(<–link). It is commonly used to keep laptops awake when the lid is closed, but there is a feature called Drive Alive that allows you to select specific hard drives which you want to constantly stay powered on and spinning. You can leave all the other settings alone so that your computer still sleeps, but enable Drive Alive so that you can keep your HDDs always powered on or even have it triggered so that once your Mac wakes it enables the drive.

I will try that app. It’s a shame that it needs the aid of a third party app. I still think there may be something else going on. Do you guys have a satisfaction policy? Or money back? This is the almost like the mother drive. It’s what I use to store things over time when they don’t fit on my smaller ones. I have thousands of pictures. I have had issues where it won’t even properly eject because it cannot communicate to the drive, but it still shows it plugged in. I don’t want it to become corrupted. Thanks for your help.

I had a similar problem with two identical My Passport for Mac 2 TB drives I purchased in January. When the Mac woke from sleep, no files or directories were visible on the drive until I force-ejected and remounted them. I went back and forth with WD tech support for months. I tried everything they suggested, and nothing worked. They replaced one of the drives with a My Passport Ultra, and it failed even more catastrophically-- when the Mac woke from sleep, the drive’s partition table became invisible to the O/S, and I had to reboot in order to get it back. WD tech support was quite difficult to work with, since the case would often be assigned to a new tech support representative every time I replied, and even when it wasn’t, they kept responding as if no one had read the conversation thus far. I had to keep repeating myself and answering the same questions over and over again. I finally stumbled upon this thread and was inspired to try uninstalling all WD software (including WD Utilities) from my Mac. It appears that that solved the problem. That’s a shame, because I also use a My Book Thunderbolt Velociraptor Duo, and WD Utilities is the only way to check the RAID status on the Duo.

This same problem bothers me for almost a year. Energy Saver settings doesn’t help stopping the drive from sleep-to-death. I have undergone a few version of the latest OSes and even now I’m on the 10.15 beta but the behaviour doesn’t change.

Amphetamine is a painful way to hide the problem but the trade off is to keep the computer awake including your internal drives – which is way shortening the lifetime of the machine. Still looking for the firmware update…

For any one stumbling across this years later like me, check out this thread. Turns out its the WD software is causing the problems. Remove all WD utilities and restart. Seems to fix the issue. Been dealing with this a very long time, and finally have a solution.

1 Like

I just made this account to confirm what @erthian wrote last year. I was going mad with my new (M1) MacBook, clean system and all of a sudden my drives not working anymore as expected.

I’m using two My Passport drives, one is a wee bit older and the other one is brand new 4TB My Passport Ultra. Every time my Mac went to sleep and got woken up after a while all the mentioned drives were completely unresponsive, no backups possible. The weirdest part was, that they stayed mounted but didn’t spin up when accessed. The isuues went away after uninstalling WD Drive Utilities.

So either don’t install any WD Software at all or install WD Drive Utilities, to setup your drive (sleep time, lighting) and uninstall it afterwards …

Regarding the age of this topic:

Dear Western Digital Team, this needs to be addressed! It seems to be an age old problem, that could get an easy fix with some software updates → Please consider doing so.

I have a WD My Passport for iMac which is the new 24 inch model. When the iMac goes to sleep for like overnight the WD drive appears to disconnect and it does not automatically update nor can i access previously backed up data. I have found that if I restart the iMac the WD drive reconnects and am able to access backed up files and it will do an automatic back up. Is this normal or is there a something i can do to keep this from happening?