My Passport don't wake up on Mac

My brand new My Passport 4TB don’t wake up when it goes to sleep.

I have downloaded and installed latest firmware with WD Drive Utillities but after some days it starts not to wake up again.

What to do?

All I get is just an empty window and no life. And when I unplug the cable it gives me error messages (unplugged wrongly).
15

When I try to eject normally it blocks because I have software open that works with a file on My Passport. Again I have to unplug the cable :worried: - or restart the whole computer.

This is utterly ■■■■!

Now I’ve tried everything with WD utilities but absolutely NOTHONG changes. I goes to sleep although I have turned that off and then it can’t wake up again.

sleep-timer

My conclusion must be that the My Passport 4TB simply is broken. What else can it be?

It is partitioned into 500gb/3,5TB but that should not cause the problems as it has been working fine for a month.

I’m having the exact same troubles as you describe. Have you found a solution yet? Did a new unit solve the problem?

WD support suggested I should unmount the drive every time I set the iMac to sleep. Useless advice, never ever had to do that with a connected hard drive.

Have you noticed by the way the drive works fine if you wake the Mac up after a short while, let’s say 5 minutes or so? It only occurs after the Mac sleeps for a longer time.

I’m in doubt to enter the RMA, as I suspect faulty firmware. Is there a way maybe to downgrade the firmware?

Alright people, found the solution. Turns out the WD Discovery software is messing MacOS up. Remove every single trace, daemons included. Problem solved!

2 Likes

Hi Yoshi83,

Yes that definitely helps! I ended up with returning my Mys Passport and got a new one while deleting all the files too (on Mac) when using it so I can’t tell exactly what helped.

How do I find the daemons?

I had a similar problem with two identical My Passport for Mac 2 TB drives I purchased in January. When the Mac woke from sleep, no files or directories were visible on the drive until I force-ejected and remounted them. I went back and forth with WD tech support for months. I tried everything they suggested, and nothing worked. They replaced one of the drives with a My Passport Ultra, and it failed even more catastrophically-- when the Mac woke from sleep, the drive’s partition table became invisible to the O/S, and I had to reboot in order to get it back. WD tech support was quite difficult to work with, since the case would often be assigned to a new tech support representative every time I replied, and even when it wasn’t, they kept responding as if no one had read the conversation thus far. I had to keep repeating myself and answering the same questions over and over again. I finally stumbled upon this thread and was inspired to try uninstalling all WD software (including WD Utilities) from my Mac. It appears that that solved the problem. That’s a shame, because I also use a My Book Thunderbolt Velociraptor Duo, and WD Utilities is the only way to check the RAID status on the Duo.

This is an outrage. I notified WD back in May 2018 what the solution was. I asked them to make a note of known problems on the download page of this software and if I could speak to an engineer to help test and fix the problem. Never heard of them again.

I recently had to replace a 10+ year old WD My Book so chose the 4Gb MyPassport. The MyBook worked perfectly from day one, the MyPassport has been a absolute pain because of the issue described above. I’ve just deleted all the software, hopefully the drive will work as intended now.

I had the same problem after switching to a new MacBook (with MacOS Mojave). I had major problems to even connect to the existing WD MyPassport drive. This was only possible after I had removed the password via WD Security. I had reactivated the password on the new MacBook, but then I realized that the MyPassport drive/folder was empty every time after the MacBook woke up. I had to do a hard eject and ignore the warning that some programs are accessing the drive. This was very annoying!

I just deleted the password via WD Security and activated encryption via Finder (right click on drive). I’m only using this drive with MacOS. For security reasons I prefer to have all data on the MyPassport drive encrypted.

Now my Mac can fall asleep and the drive is still accessible after a wakeup. I haven’t remove the WD utilities so far (WD Drive Utilites and WD Security).

Hope this may help for other users with the same problem.

I tried this based on suggestion here with Thanks to @Yoshi83 and it seems worked for me.

I removed WD Discovery software, uninstalled from my iMac and restarted. After that, I left iMac unattended to let it go in sleep mode, overnight as well as manually selected Sleep from Apple menu options. Every time when I woke it up, these WD drives are now being active and all volumes are up and running.

Wester Digitial team - If you are reading this, please fix your WD Discovery software. It was supposed to solve a problem, not to be a Problem… Thanks again to @Yoshi83.

Regards,
Neeraj