External drive not recognised after restart

I have 3 WD external drives connected to my PC. When I start/restart my computer one of the drives is not recognised, the other 2 are OK. I have to unplug the drives USB cable an reconnect it before its recognised. I am running Win 11. The drive is a 2TB my book essential.
Any suggestions?

Hi @andrew1001,

Please refer to the mentioned link: Cannot Find My WD Drive on Windows or macOS: Cannot Find My WD Drive on Windows or macOS

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:https://support-en.wd.com/app/ask

To rule out the most frequent mistakes, start with the simplest tricks:

  • Attach the drive to a different computer port.

  • Use the same port to connect a different hard disk or flash device.

  • Link the drive to a different computer.

  • Use a compatible cable to connect the drive.
    A more involved remedy should be tried if the drive is still not detected:

1. Check if it is listed in Device manager
By entering “Device Manager” in the charms-search bar’s box and clicking on the corresponding icon, you may access Device Manager. As an alternative, you might hold down the Windows key and the R key, open the Run dialogue box, type diskmgmt.msc, and then hit Enter. The item will be listed in the window that appears if the computer is detecting it.
2. Disconnect and reinstall the hard disc.
You could try removing the hard drive’s driver. To do this, select Uninstall from the context menu by right-clicking the drive in the Device Manager’s list. When that is finished, wait a short while before unplugging the hard disc from the computer. If everything is in order, plug it in again, and the driver should automatically reinstall and the usual events take place.
3. The last resort, if everything else fails, could be to do a system restore to a time when everything functioned as it should. Save a copy of your most recent data, then reset the machine to a previous system restore point.
Hope this help