External drive enclosure not recognize by WD


#1

Anyone else have an external drive enclosure (with an internal WD “green” drive inside) that doesn’t get seen by Live?  The drive works great on my PC, but Live never sees it no matter what I do (it has a power switch and I’ve tried plugging it in switched off, switched on, plugging in USB first, then power, reverse, every combination you can think of).  Same cables work fine with my other external drives, so it’s not a cable or other such issue.

On my PC the drive is recognized the moment I turn on the power switch, in either Win 7 or XP. 

At this point I’m not blaming Live per se – it probably is an enclosure issue that requires the unit it’s plugged into to somehow poll it and Live is probably looking for the reverse – but I just wondered if someone else had an issue they were able to resolve.  Otherwise I’ve got a 1.5TB drive that’s basically just a backup drive now .


#2

mkelley… Try unplugging the WD and plug back in… Sorta reboots the device. I have had to do this once in a while with mine when used with a USB HDD. Make sure that you always eject the USB device before powering off the unit. This can cause the WD not to see the USB HDD the next time

1.5TB hold a lot of media…

cj


#3

mkelley wrote:

Anyone else have an external drive enclosure (with an internal WD “green” drive inside) that doesn’t get seen by Live?

I did and finally gave up and bought a new enclosure. :slight_smile: The only way I could get it to recognize was to do a system reset while drive was on.

Not sure what it is about the enclosure that WD Live wouldn’t connect, but it works fine on my XP machine.


#4

Yes, I’m afraid that’s where I’m at (for the other poster – yep, did try plugging and unplugging Live with drive on – still no-go).

It’s a bummer because this drive enclosure is top rated and otherwise a dream.  At the moment I think I’ll just pass on getting another (I have a couple of external drives that, while much smaller, work fine at the present).  I think I’ll wait at least until the end of the year, when it’s likely that 1.5TB external drives themselves will be around $80 (mark my words :>).

But thanks for both of your replies.


#5

Just to clarify, the only way mine would work was by going into /Settings/System Settings/ and hit reset to factory defaults while drive was running, then it connected on reboot.


#6

Right, I understood you – but no point in resetting all factory settings every time I want to see the drive (even assuming that worked).

It’s probably a software bug if your procedure worked – shouldn’t be any reason why the Live can’t do this without a factory reset and reboot.


#7

Anyone else have an external drive enclosure (with an internal WD “green” drive inside) that doesn’t get seen by Live? 

 

I have a WD Elements external powered USB unit, which according to the serial number contains a 1.5Tb WD “Green” drive.  I partitioned this, via my PC, into two NTFS partitions 500Gb + 1Tb.  I then plugged the drive into the USB port of my LinkSys WRT610N router and used the media server feature to set up Music, Video and Photos DLNA “shares” on the 500Gb partition.

My HDTV Live is wired directly into the same router and can see the Elements drive “shares” under both the media server and networking sections.

When the Elements drive is plugged directly into the HDTV Live, it is also recognised and read correctly under the local media section.

So, in answer to your question, there is no reason why your “Green” series drive should not be read by the HDTV Live, unless HDTV Live does not support huge single partitions.  Have you tried plugging it into your PC and running CHKDSK /F on the drive, just in case your FS is corrupt?

Please note, however, that the HDTV Live has numerous issues with connectivity drop-outs on network connected media.


#8

No, I’ve already used the drive (attached to my PC) wireless from the Live – it’s not the drive, it’s the enclosure that’s the issue, I’m pretty sure. For some reason Live doesn’t “wake it up” properly or something. I’ve never had connectivity issues with my Live – which is to say I’ve streamed video (1080p) wirelessly and never had a disconnect. However, at times I have trouble connecting initially (usually resolved when I reboot the Live). I actually really want to just use my PC as a network share since I can then share the 5TBs that’s in it, but because of the thumbnail bug I can’t (hopefully, one day, it will be fixed. Then again, I still believe in Santa Claus).


#9

Mkelley,

I would like to hear more about your wireless streaming to the WD LIve.  I have not heard from anyone who was able to make this work without lots of pausing and pixilation which occurs durng the Raleigh fading of the link–that can’t be avoided unless both wireless adapter at the WD live is next to the wireless router–in which case- what would be the point of a wireless connection? 

What can you provide to the group? 


#10

There’s nothing particularly remarkable about my setup – the router is about 30 feet away from the unit, I’m using a USB wireless adapter from the WD list (can’t say offhand which one it is but I’ll go look at it after I get up from the computer room). My “server” such as it is is just an old dual core Pentium (top of the line five years ago, but that was five years ago). The PC is attached directly to the router (only my wife’s PC is wireless – the other four are all hard wired into the router). The router is also fairly old (a Linksys and probably at least five years if not more). Now – I haven’t played a ton of movies because (as I noted) the thumbnail bug really keeps me from using this as my media source. But I’ve played at least two or three without issues. (And these are blu-ray rips, full resolution, and around 4gb). Sound is either AC3 or DTS surround. Given that I can’t get my external drive to work otherwise I’m going to test playing movies off of it as it’s attached to the server via USB (I figure this is the harshest possible test since the drive itself has a tendancy to go to sleep in the external enclosure). I was planning on doing some of those tests this weekend (in between NCAA games :>) because I need to figure out what I’m going to do, disc wise (my plan had been to have this 1.5TB attached directly to the Live, but since that doesn’t work sharing it via my network might be the way to go). I’ll keep you posted.


#11

Just got through watching “How the West was Won” (smiley edition – terrific blu-ray and I highly recommend it to anyone with a large screen – on our 55" Samsung LED it was brilliant).

Anyway, after nearly three hours of flawless wireless streaming 1080p (from an external drive connected to a PC directly wired to the router) I can only conclude that those of you unable to do this are doing one of two things wrong:

  1. You are trying to stream too large a file.  I haven’t tried playing a “raw” m2ts file, but I suspect the data rate for such a file would be too high even on my 2.4mz G network router.  If you haven’t already, make sure you encode your files so they aren’t larger than around 2-3GB per hour (I use Handbrake with the high standard settings passing through the DTS or AC3 compressed tracks and the rips are flawless).  I also use the mkv container – not sure if this makes a difference, but it seems to play extremely well on the Live.

  2. You aren’t using a fast enough PC to serve the data.  It shouldn’t take a monster – as I said earlier, I’m using a five year old dual core PC, but it’s pretty well dedicated to this (I also use it to serve my TiVOs).  I wouldn’t try directly connecting drives to the router – the PC will push the data correctly.

Other than that I don’t know why it *wouldn’t* work – and I can’t imagine I’m the only person who’s doing this or something similar.  Now if they’d only fix the #$@@$ thumbnail bug I’d be a happy camper (as it is I have to scroll down five pages of jpegs before I get to my movies)