WD TV LIve won't recognise external drive

Hi I bought a wdtv live about a month ago, and an external hdd, also WD. Had movies on it and it worked fine. Recently it stopped working, and also started takign ages to turn on and seeming spasmodically unresponsive to the remote.

So I returned the WDTV live to the shop today and had it replaced. Same prob. It cannot see the hard drive that I have tried plugging into both usb ports. Could it be some sort of formatting or something that the pc has done to the hard drive, when I copied files onto it? I can’t see why, but I can’t understand why when I tell it to access local content, it tells me nothing is there, when there is!

wha’t the capacity of the drive that you are using?

I have the same problem since a few month back (2012).

I have a WD 1TB. It has owrked perfectly with my WD Live Tv for a year!!

I have done factory reset and still it does not work

I have tried another WD USB disk and same problem. It will not read the files or hang.

But with small USBs 4Gb it works ok.


I got WDTVLIVE (with  up to date official firmware) since many months, working fine with disks of 1 to 2 TB (all WD). Then I bought a 3 TB My Book Essential and it worked OK for a couple of weeks. Then it started to stop playing movies after a few minutes (blocked on an image and after a few minutes, full crash of the WDTVLIVE). Note that these files are played OK on a PC, without any glitch.

Since a few days, the 3TB external harddrive is not recognized any more. It blinks a few time when switched on, but the WD TV Live does not recognize it anymore. I have removed the .wd_tv folder at the root, reset the device to factory settings, but still nothing. My other drives of 1 to 2 TB are still playing fine.

Any idea?

I have had sporadic problems with a 1Tb WD elements drive connected to my WDTV Live. I reformatted the drive in windows, connected to one of the computer USB ports, then plugged it back in to the WDTV live have not experinced problems since. Maybe worth a try but if you have a lot of data on your drive and no back up its a pain movie all your files…


I’ve got the same problem. Its the front usb port. My WDTV live player works perfectly with a 4tb drive at the back but nothing, but nothing, works in the front. It’s not a problem with the capacity of the drive.

This is a serious problem with the WDTV Live and it’s just happened after the last firmware update. I’ve never had a problem with it, I have two and both worked like a dream until recently.

The answer can’t be “format the drive and re paste the files on it” surely?? Most people are using 2tb drives so you’re looking at a day of transferring files at the very least!

Come on people, surely someone has answer t this? I’m seriously thinking of dumping both of my media players if this continues!

I’m having the same problem with my WD Elements 500Gb (formatted NTFS). Other drives work fine I have tried work fine, and this drive has worked fine on a couple of different brands media players. What gives WD?

I had some trouble with that particular drive too with my WDTV Live, I reformatted (NTFS) in Wndows and no problems since.

I have bought a brand new wd live tv device and it has never recognised any usb hdd that I plug in. My samsung blu ray player recognises all my drives with no problem at all. What could be the issue?

Yeah, they just love having morons b.i.t.c.h about the same thing in 3 threads.

No, I’m only talking about you. The others complain instead of whining and most importantly they don’t spam the forums.

Hi all,

I asked a friend of mine to test my WD Live since none of my external HD (500GB nor 1TB) worked after the latest software update. He tried his and it workes perfectly with his HDs.

So, the issue must be my HDs. I wil now buy a 2TB and backup my other data and then reformat the old ones and have a go. 

You should try also and see if you have the same fault.

good luck!

icewoman >>>>  I asked a friend of mine to test my WD Live since none of my external HD (500GB nor 1TB) worked after the latest software update. He tried his and it workes perfectly with his HDs.

So, the issue must be my HDs.

Not necessarily.  Since I have not seen these suggestions made in this thread, I will mention to you and others with HD problems w/WD:

1.  Eject HD from WD, turn off power to WD. Remove the HD from the WD unit and connect it to your computer.  Does it work now?

2.  If you get a message that the drive has errors and needs to be scanned, do it.

3.  While the drive is on the PC, delete the hidden folder named .wd_tv (your PC must be set to see hidden files.)  This is a cataloging folder of the contents of the HD; it could be corrupted.  It will be reconstructed when you re-attach the drive to the WD and turn it on…

4.  With the WD unit off, re-attach the HD.  Boot WD.  Wait for HD activity to stop.  Now, does it all work again?