exFat G-Drive will not mount on iMac OS X 10.11.6

I have a 6TB G-Drive with Thunderbolt. It was given to me by a client for a video project. They formatted it exFat as they run Mac and PC in house. I can see the drive showing up in disk utilities but “mount” is greyed out so I cannot mount the drive on my system. The client says the drive shows up on their Macs. In fact they have given me two of these drives. Neither mounts on my Late 2015 running OS X 10.11.6 The same thing happens on my older desktop Mac Pro 2009 running the same OS.

Am I missing something? Are there drivers that I should be running for this?

Thank you for any and all help. I’m in a crunch here.

It should mount just fine as exFAT support has been in Mac OS for a few years now and 10.11 will definitely support it.

It is possible the partition is corrupted to an extent that your system doesn’t want to mount it.

If you launch the Disk Utility you can see the drive and if selected check below at its details. It will have a Device ID of sorts something along the lines of “disk3s2” It might not be that exactly but it will be similar.

If you can figure out which drive it is showing as then you can run a command on the Terminal.

Below is the command you type into Terminal:

sudo fsck_exfat -d disks

  • Replace * with the drive numbers as shown in disk utility.
  • sudo will require you to enter your computer’s administrative password
  • When it prompts: Main boot region needs to be updated. Yes/No? Type yes.

After a reboot of the machine the drive should mount and be usable.

First of all Thank You very much for replying and helping me with this problem.

This is what I get as a response from the instructions you gave me:

“fsck_exfat: Cannot write main boot region: Bad file descriptor
** The volume ADELANTO 2 could not be verified completely.”

Here is what I did to get the above response:

I ran the terminal commands as directed. Here is what I got . . .

I ran “diskutil list” first and got this:

/dev/disk3 (external, physical):
0: GUID_partition_scheme *6.0 TB disk3
1: EFI EFI 209.7 MB disk3s1
2: Microsoft Basic Data 6.0 TB disk3s2

Then I ran the command you gave me as follows: “sudo fsck_exfat -d disk3s2”

This is the response though I’m only listing the first few lines as the rest is quite long and it looks like file and directory names mostly.

“Shannons-iMac:~ shannonnoble$ sudo fsck_exfat -d disk3s2
fsck_exfat: Opened /dev/rdisk3s2 read-only
Opening /dev/rdisk3s2
** Checking volume.
** Checking main boot region.
fsck_exfat: Invalid boot region checksum
Main boot region is invalid. Trying alternate boot region.
** Checking alternate boot region.
11720373344 total sectors; 512 bytes per sector
FAT starts at sector 32768; size 196608 sectors
22890906 clusters starting at sector 229376; 262144 bytes per cluster
Root directory starts at cluster 14
Read offset = 0x000001000000 length = 0x001000
** Checking system files.
Read offset = 0x000007300000 length = 0x040000
** Volume name is ADELANTO 2.
Found active bitmap; first cluster 2, length 2861364
** Checking upper case translation table.
Read offset = 0x0000072c0000 length = 0x040000
Found upcase table; starting cluster 13, length 5836
** Checking file system hierarchy.”

At the end of the list of files and directories I finally get this:

"** Checking active bitmap.
Checking bitmap cluster 2
Read offset = 0x000007000000 length = 0x040000
Checking bitmap cluster 3
Read offset = 0x000007040000 length = 0x040000
Checking bitmap cluster 4
Read offset = 0x000007080000 length = 0x040000
Checking bitmap cluster 5
Read offset = 0x0000070c0000 length = 0x040000
Checking bitmap cluster 6
Read offset = 0x000007100000 length = 0x040000
Checking bitmap cluster 7
Read offset = 0x000007140000 length = 0x040000
Checking bitmap cluster 8
Read offset = 0x000007180000 length = 0x040000
Checking bitmap cluster 9
Read offset = 0x0000071c0000 length = 0x040000
Checking bitmap cluster 10
Read offset = 0x000007200000 length = 0x040000
Checking bitmap cluster 11
Read offset = 0x000007240000 length = 0x040000
Checking bitmap cluster 12
Read offset = 0x000007280000 length = 0x040000
0 clusters were marked used, but not referenced
0 clusters were marked used and CLUST_BAD
0 clusters were marked free, but referenced
** Rechecking main boot region.
Main boot region needs to be updated.
Update? yes
fsck_exfat: Cannot write main boot region: Bad file descriptor
** The volume ADELANTO 2 could not be verified completely.
Shannons-iMac:~ shannonnoble$ "

Like I said. I checked these drives on 3 Macs running 10.11.6 and one PC. Client says they are using the same operating system on Macs.

Thank you again for your help!

The best option if it still works on other systems is to have them move the data off, then reformat the drives with a clean exfat and then put the data back on.