Another WD Passport Ultra 2TB not mounting in 10.9

I know there are other threads about this but many of them are dated and I haven’t found a solution in any of them.

The drive is formatted exfat directly to my MBP late 2012 13". I purchased it last November and it has worked for several months but I have only used it a handfull of times.  A few days ago without any movement it said “please eject the drive properly” and when unplugged - replugged the drive it simply flashes forever. It shows up in disk utlity and it won’t mount it just flashes.

The drive shows up in my Windows 8 partition with the data intact and I updated to the latest firmware. Thank god I formatted it exfat…

Disk utility gives me this error when I try to repair: “Error: Disk Utility can’t repair this disk… reformat the disk, and restore your backed-up files”

I am a photographer and it’s my backups and work drive and I am on assignment MILES away from anywhere that I can buy another drive to back everything up. I neeeeeed to access this data as my project is on there and I don’t have the space on my MBP to move anything there (which is why I got the external drive).

I have been a WD ONLY customer for 15 years and I put my trust in WD to protect my data.

I contacted customer support who replied: 

Thank you for contacting Western Digital Support.

If it is possible, please backup all data form the drive and then format it. 

Blah blah blah

I apologize for any inconvenience this has caused.

Has ANYONE found a solution? I can’t imagine EVER buying another WD drive after this! I can’t ever have this happen again!!! 

Note: I tried to answer as many possible questions in the post so this does not turn into countless posts asking me ridiculous questions as I am looking for someone who has found a solution… Well besides reformatting.

Have you tried using another file system like FAT32?

We understand that the exFAT file system does not have as much limitations as FAT32. However, when using a drive with Mac OS X 10.9 we recommend the latter.

There are also some alternate solutions posted on the Community to use the drive while formatted to only one OS by using in conjunction with an app that allows you to overcome the file system limitations.

WD does not recommend nor support any specific application.

Please see the link bellow for more information:

How to format a WD external hard drive in exFAT or FAT32 (to use in Windows or Mac OSX)


It could also be a power issue.

Make sure the drive is connected directly to the Laptop and not an USB hub.

You can also try another USB cable.


“Have you tried reformatting the drive to an inferior file system with major limitations?”

Formatting is not an option. FORMATTING IS NOT AN OPTION.

If someone from WD or Apple would say “Yes, there is a blatant problem with 10.9 and exfat, don’t use it!” (backed up by a link) I would feel a bit relieved. That would put the blame on Apple and it would take the hatred I feel for WD away.

And if there is a major problem with 10.9 and exfat why wasn’t this explained to me in my support emails? 

Looks like I am going to have to dump money into a second external drive to get everything off of this. Right now I can’t EVER see myslef buying another WD drive. This can NEVER happen again and since nobody has a reason for it… I am blaming WD for this problem.

I use this drive for my work and I can NEVER have another OOPS moment like this happen again when I am in the field.

and… as I stated above it’s plugged direclty into my macbook.

Thanks for the “support” WD… 

We are sorry you feel that way.

Please bare in mind that what you are doing is not the standard use for an extenarl drive

As you might now, there are certain issues and limitations that come with  the use of a drive with two different platforms.

Regardless of the brand name for the drive the file system will need to be changed to allow connectivity.

Each file system has its own advantages and limitations.

To achieve the best performance possible using any external drive is recommended to format for one OS only.

However, if you want to use it to cross platforms you can do it by using one application or formatting on another file system.

For additional information and troubleshooting options please contact support directly.